POJ 2533 O(nlogn)解最长递增子序列(构造法)

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 41083 Accepted: 18109
Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input

7
1 7 3 5 9 4 8
Sample Output

4

题意:
求一个序列的最长递增子序列,输出这个子序列的长度。
解法:
这是一个经典的dp问题,转移方程是dp[i] = dp[j] + 1,0 < j < i-1,并且j是在a[j] < a[i]范围内dp[j]最大的。由于每次寻找时,我们知道在a[j] < a[i]的范围内dp[j]是最大的。因此要顺序便利,这样总时间复杂度就是O(n^2)
给人的感觉就是在搜索j时顺序遍历太不聪明了。这一步应该有更好的办法。由此有二个算法。
考虑构造一个数组b[],这个数组里放的是已经找到的最优递增序列,那么,我们开始遍历a[i],如果a[i]比数组b[]最大一个元素(即最后一个元素)还要大。那么就把a[i]添加到数组b[]的尾部。如果不比最后一个元素大,那就在b[]里查找第一个比a[i]大的元素,然后将那个元素替换为a[i].保证b[]里面的元素是递增排列的。并且当a[i]可以替代b[]里的元素时进行替代。由于b[]里元素是有序的。因此可以用二分查找,就达到了优化的目标。时间复杂度变为O(nlogn).
在poj上此题用上O(nlogn)的算法,时间降从原来dp算法的16ms到0ms

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

int a[10010];
int b[10010];

int main()
{
    int n;
    scanf("%d",&n);
    int i,j;
    for(i = 1;i<=n;i++)
        scanf("%d",&a[i]);
    b[1] = a[1];
    int cnt = 1;
    for(i = 2;i<=n;i++){
        if(a[i]>b[cnt]) b[++cnt] = a[i];
        else{
            int k = lower_bound(b+1,b+cnt+1,a[i]) - b;
            b[k] = a[i];
        }
    }
    printf("%d",cnt);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值