POJ 1260 DP

Pearls
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8068 Accepted: 4025

Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class.
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the
prices remain the same.
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one.

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000).
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.

Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12
Sample Output

330
1344
题意:
给许多种的珍珠的一个清单,每一种珍珠有个数和价格,必须要买清单上那么多个数的珍珠,买n个D第i种珍珠的付款方式为(n+10)*p[i],但是可以用单价比低价高的珍珠替换单价比较低的珍珠。求使得满足购买个数的最少付款钱数。
解法:
dp[i]是挑选完前i种后所付出最少的价格。在推dp[i]时,前几种珍珠用第i总取代。dp[i]初始为dp[i-1]+(a[i]+10)*p[i].让后从这些中找一个最小的赋值给dp[i]

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define F(i,a,b) for(int i = a;i<=b;i++)

using namespace std;

int a[200];
int p[200];
int sum[200];
int dp[200];

int main(){
    int N;
    scanf("%d",&N);
    while(N--){
        int n;
        scanf("%d",&n);
        sum[0] = 0;
        F(i,1,n){
            scanf("%d%d",&a[i],&p[i]);
            sum[i] = sum[i-1] + a[i];
        }

        dp[0] = 0;
        F(i,1,n){
            dp[i] = dp[i-1] + (a[i] + 10)*p[i];
            F(j,0,i-1){
                dp[i] = min(dp[i],dp[j]+(sum[i]-sum[j]+10)*p[i]);
            }
        }
        printf("%d\n",dp[n]);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值