opencv3.0+VS2013 debug运行出错,release模式正常

原创 2016年08月30日 21:06:29

调用opencv中自带的函数时,debug总是会出现如下问题,但是release模式下正常运行,问题状况和解决办法如下:
这里写图片描述

原因是由于工程属性中链接器中输入的附加依赖项与运行模式不匹配,对于opencv3.0来说,debug模式下的附加依赖项中有两个文件,即opencv_ts300d.lib,opencv_world300d.lib;而在release模式下则为opencv_ts300.lib,opencv_world300.lib; 因此如果出现该种问题则修改项目的属性即可

这里写图片描述

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

opencv3.0&vs2013 debug下可以运行 release下不能运行或者release 下可以运行debug下不能运行的解决办法

opencv3.0&vs2013 debug下可以运行 release下不能运行或者release下可以运行debug下不能运行的解决办法,类似错误为“。。。。。写入位置0x00000010”时发...

Debug调试运行正常,但在Release模式下退出程序时报错

在最近的H.265分析器项目中,出现了一个问题,就是在Debug模式下运行正常,但是在Release模式下时,退出程序时,会报出以下错误:the instruction at"0x78d80f87" ...

vs下debug运行正常,release下出现异常

VC下Debug和Release区别 最近写代码过程中,发现 Debug 下运行正常,Release 下就会出现问题,百思不得其解,而Release 下又无法进行调试,于是只能采用printf方...

[OpenCV] VS2010中OpenCV2.X配置Debug和Release同时正常使用

由于引用的Debug和Release中lib不同,所以会在附加依赖项产生冲突,表现为Debug可以用而Release不能用或反之。

【OpenCV配置之二】VS2013:LNK2038 RuntimeLibrary不匹配问题(Release Debug混合错误)

最近为了运行从github上下载的背景算法提取代码,我为我的Visual Studio配置了OpenCV和Boost1.61的环境。 OpenCV大家都很熟悉,Boost库是由Boost社区开发支持...

Win10+VS2015平台下OpenCV3.1.0的x86和x64平台的Debug与Release模式的编译与配置

Win10+VS2015平台下OpenCV3.1.0的x86和x64平台的Debug与Release模式的编译与配置

Opencv学习笔记——release和debug两个模式的运行问题

本文为原创作品,转载请注明出处 欢迎关注我的博客:http://blog.csdn.net/hit2015spring和http://www.cnblogs.com/xujianqing/ 作者:...

VS2010+opencv中Debug下运行,Release下运行,其中一个不能成功的原因。

由于将VS配置opencv时,选择了永久配置,

Debug下正常运行,但调成Release时遇到三个问题及其完美解决!

----------------------------------------------------------------------------------------------------...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)