hdu 3579 Hello Kiki(求解线性同余模方程组的正整数解模板题)

Hello Kiki

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2354    Accepted Submission(s): 862


Problem Description
One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again...
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.
 

Input
The first line is T indicating the number of test cases.
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi
 

Output
For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.
 

Sample Input
  
  
2 2 14 57 5 56 5 19 54 40 24 80 11 2 36 20 76
 

Sample Output
  
  
Case 1: 341 Case 2: 5996
 

Author
digiter (Special Thanks echo)
 

Source
模板题,注意0的时候加上lcm
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX 10000

using namespace std;

typedef long long LL;
LL t,n,a[MAX],b[MAX];

void exgcd ( LL a , LL b , LL& d , LL& x , LL& y )
{
    if ( !b )
        x = 1 , y = 0 , d = a;
    else
        exgcd ( b , a%b , d , y , x ),
        y -= x*(a/b);
}

LL solve ( LL n )
{
    LL ta,tb,c,d,x,y;
    for ( LL i = 1 ; i < n ; i++ )
     {
        LL ta = a[0] , tb = a[i] , c = b[i] - b[0];
        exgcd ( ta , tb , d , x , y );
        if ( c%d ) return (LL)(-1);
        LL t = tb/d;
        x = ( (x*(c/d))%t+t)%t; 
        b[0] = a[0]*x+b[0];
        a[0] = a[0]*(a[i]/d);
    }
    if ( b[0] == 0 ) return a[0];
    return b[0];
}

int main ( )
{
    scanf ( "%lld" , &t );
    int c = 1;
    while ( t-- )
    {
        scanf ( "%lld" , &n );
        for ( LL i = 0 ; i < n ; i++ )
           scanf ( "%lld" , &a[i] );
        for ( LL i = 0 ; i < n ; i++ )
           scanf ( "%lld" , &b[i] );
        printf ( "Case %d: %lld\n" , c++ , solve(n) );
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值