【九度】题目1440:Goldbach's Conjecture 2

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:1372

解决:887

题目描述:

Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2. 
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

输入:

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.

输出:

Each output line should contain an integer number. No other characters should appear in the output.

样例输入:
6
10
12
0
样例输出:
1
2

1



#include "stdafx.h"
#include <algorithm>
using namespace std;
int prime[10001];
bool mark[10001];
int primesize;
void init(int x){
	for (int i = 0; i < x; i++)
	{
		mark[i]=false; //初始化标记数组
	}
	primesize=0;
	for(int i=2;i<=x;i++){
		if (mark[i]==true) //如果被标记了,则不是素数,执行下一次循环
		continue;
		prime[primesize++]=i;//将素数存入数组里面
		for (int j = i*i; j <=x; j+=i)//如果这个数字是素数,那么将其倍数的所有数字都标记为非负数
		{
			mark[j]=true;
		}
	}
}
int main(){
	int n;
	
	while (scanf("%d",&n))
	{
	init(n);
	sort(prime,prime+primesize);
	/*for (int i = 0; i < 10; i++)
	{
		printf("%d ",prime[i]);
	}
	printf("size:%d ",primesize);*/
	int low=0;
	int high=primesize-1; 
	int sum=0;	
	for(low=0;prime[low]<=n/2;low++)
		for (high =primesize-1; prime[high]>=n/2; high--)
		{if((prime[low]+prime[high])==n)
		 sum++;
		}

	printf("%d",sum);
}return 0;
}
有了上个题筛选数组的基础,通过预处理,将所有素数保存到了一个数组中。

在这个基础上面,增加了一些改动,使得处理的时间和规模更加精简。

1、预处理函数增加了 int n的形参,将不大于n的所有数字全部保存进入数组。

2、将数组排序,以N/2为边界进行筛选。有效降低了遍历时间,同时也满足了题目所要求的条件。 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值