POJ 3617 Best Cow Line(字典序最小问题)

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD


题意:

给定长度为N的字符串S,要构造一个长度为N的字符串T。起初,T是一个空串,随后反复进行下列任意操作。

从S的头部删除一个字符,加到T的尾部

从S的尾部删除一个字符,加到T的尾部

目标是要构造字典序尽可能小的字符串T。


解题思路:

贪心做即可。每次从头部和尾部选择最小的,若相等则向中间搜索。

虽然思路很简单,但是代码实现还是有一点技巧的。头尾相等向中间搜索时,我第一次设了两个循环变量,分别控制头指针和尾指针的移动,结果死循环了。技巧是设一个循环变量 i ,则头指针是 a + i ,尾指针是 b - i 。相等时 i++ 向中间搜索。头尾相遇前若不相等则会跳出循环,否则说明该字符串头尾对称,因此输出哪个都可以。


#include <iostream>
using namespace std;

int N;
char s[2005];

int main(int argc, char const *argv[])
{
	while(cin>>N)
	{
		for(int i = 0;i < N;i++)
			cin>>s[i];

		int cnt = 0;
		for(int i = 0,j = N-1;i <= j;)
		{ 
			bool left = false;	
			for(int p = 0;i+p <= j;p++)
			{
				if(s[i+p] < s[j-p])
				{
					left = true;
					break;
				}
				else if (s[i+p] > s[j-p])
				{
					left = false;
					break;
				}
			}
			
			if(left)
				cout << s[i++];
			else
				cout << s[j--];
			cnt++;

			if(cnt == 80)
			{
				cout<<endl;
				cnt = 0;
			}
		}

		if(cnt)
			cout << endl;

	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值