POJ 1979 Red and Black (DFS水题)

1 篇文章 0 订阅

今天确实是值得纪念的一天


终究决定重拾放下了很久(几个月)的ACM


跟着老师做了几个月IOS,做出了自己的第一个APP(我负责是前端)


虽然很low,但终究是自己的第一个APP作品,在杭州的寒冬唯一能让我感到温暖的也就只有这个了


忙完这个之后,就开始准备3月的ACM校赛了


1个多月时间...还是太短了点,先做道水题热热身

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题目描述:意思就是你处在@点,#点无法通过,问最多能走过多少的.点(可以重复走)。

思路:每走一步,DFS一遍即可。

#include <cstdio>
#include <cstdlib>
#include <iostream>
using namespace std;
int m,n;
int _x,_y;
char map[21][21];
int visited[21][21];//标记是否经过 
int cut=0;//总步数 
bool check(int i,int j){
	if(map[i][j]=='.'&&i<m&&j<n&&i>=0&&j>=0&&visited[i][j]==0)
		return true;
	return false;
}
void DFS(int x,int y){
	cut++;
	visited[x][y]=1;
	if(check(x+1,y)) DFS(x+1,y);
	if(check(x-1,y)) DFS(x-1,y);
	if(check(x,y+1)) DFS(x,y+1);
	if(check(x,y-1)) DFS(x,y-1);
}
int main(void){
	while(cin>>m>>n,m,n){
		int t;//注意这题先输入列再输入行! 
		t=m;
		m=n;
		n=t;
		cut=0;
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++){
				cin>>map[i][j];
				if(map[i][j]=='@'){//标记出发点 
					_x=i;
					_y=j;
					map[i][j]='.';
				}
			}
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				visited[i][j]=0;
				
		DFS(_x,_y);
		cout<<cut<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值