POJ 3723 Conscription 克鲁斯卡尔+并查集

Conscription
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11318 Accepted: 3997

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source

    题意:招人,招收每个人需要花费10000元,男女生之间存在关系的话,则可以少花关系值的钱。关系不可重复使用,问最终所花的最少的招人费用。

    分析:要使招人费用最少,就要使得关系和最大,这里将每个关系抽象为一条边,最终根据这些边生成的子集树的代价最大即为所求最大。这里使用克鲁斯卡尔算法,克鲁斯卡尔算法求最小代价生成树是将边排序,每次选出最小的边判断其端点是否是属于两个不同的子树,是的话则加入此边,不是的会就会造成回路,此边舍弃。此题所求为最大代价生成树,原理相同,将边以非递减顺序排序即可。判断是否属于同一子树,在此用并查集实现即可。注意男女序号都是从0开始,并查集实现时需要区分男女序号。见AC代码:

//该题的意思是要最终所花费用最小 即减少的费用最大
//即求最大生成树  两个人之间的关系抵消掉的值 即为边值
//要让边值的和最大
//按照边长  从大到小排序
//每次选取一条边  该边的一点已被选上  另一点未被选上
//使用的是克鲁斯卡尔算法算法
#include<stdio.h>
#include<algorithm>
using namespace std;
const int maxn=50005;
int n,m,r,maxtree,res;//res表示最大生成树的边长之和
int pre[maxn];
struct  edge
{
	int u,v,w;
} a[maxn];
int cmp(edge a ,edge b)
{
	return a.w>b.w;
}
int find(int x)                                      
{
	int r=x;
	while (pre[r]!=r)
		r=pre[r];
	int i=x,j ;
	while( i != r )
	{
		j=pre[i];
		pre[i]=r ;
		i=j;
	}
	return r ;
}
void join(int x,int y)
{
	int fx=find(x),fy=find(y);
	if(fx!=fy)
		pre[fx]=fy;
}
void kruskal()
{
	maxtree = 0;
	for(int i = 0; i < r; i++)
	{
		int fa=find(a[i].u);
		int fb=find(a[i].v+n);
		if(fa==fb)
			continue;
		else
		{
			join(a[i].u,a[i].v+n);
			//	printf("加上%d\n",a[i].w);
			maxtree+=a[i].w;
		}
	}
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d",&n,&m,&r);
		for(int i=0; i<r; i++)
		{
			scanf("%d%d%d",&a[i].u,&a[i].v,&a[i].w);
			pre[a[i].u]=a[i].u;
			pre[a[i].v+n]=n+a[i].v;
		}
		sort(a, a + r, cmp);
		kruskal();
		int res=(n+m)*10000-maxtree;
		printf("%d\n",res);
	}
}

    特记下,以备后日回顾。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值