1025. PAT Ranking (25)

1025. PAT Ranking (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

提交代

http://www.patest.cn/contests/pat-a-practise/1025

#include <cstdio>  
#include <sstream>  
#include <cstring>  
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <map>
#include <iterator>
#include <sstream>

using namespace std;

struct stu
{
  char no[15] ;
  int score ;
  int location_number ;
  int rank_final ;
  int rank_local ;
} ;

bool cmp(stu s1 , stu s2)
{
  if( s1.score > s2.score )
    return true;
  if( s1.score == s2.score )
    if(strcmp(s1.no , s2.no ) < 0 )
      return true ;
  return false ;
}

int main()
{
    //freopen("in.txt", "r", stdin);
  int n  , i ;
  int k ;
  vector<stu> vtAll ;
  scanf("%d" , &n) ;
  vector<stu> vt ;
  int finalnum = 0 ;
  for(i = 0 ; i < n ; i++)
  {
    vt.clear() ;
    scanf("%d",&k) ;
    finalnum += k ;
    stu st ;
    st.location_number = i + 1 ;
    for(int j = 0 ; j < k ;j ++)
    {
      scanf("%s%d",st.no , &st.score) ;
      vt.push_back(st) ;
    }
    sort(vt.begin() , vt.end() , cmp);
    vt[0].rank_local = 1 ;
    vtAll.push_back(vt[0]) ;
    for(int j = 1 ; j < k ; j++)
    {
      if(vt[j].score == vt[j-1].score)
        vt[j].rank_local = vt[j-1].rank_local ;
      else
        vt[j].rank_local = j + 1 ;
      vtAll.push_back(vt[j]) ;
    }
  }
  sort(vtAll.begin() , vtAll.end() , cmp);
  vtAll[0].rank_final = 1 ;
  for(int j = 1 ; j < finalnum ; j++)
  {
    if(vtAll[j].score == vtAll[j-1].score)
      vtAll[j].rank_final = vtAll[j-1].rank_final ;
    else
      vtAll[j].rank_final = j + 1 ;
  }
  printf("%d\n" , finalnum);
  for(int j = 0 ; j < finalnum ; j++)
  {
    stu stmp = vtAll[j] ;
    printf("%s %d %d %d\n" ,stmp.no , stmp.rank_final , stmp.location_number , stmp.rank_local) ;
  }
  return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值