POJ 1423 Big Number

324 篇文章 134 订阅
315 篇文章 4 订阅

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.
Output

The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input

2
10
20
Sample Output

7
19

(部分转载)
补充知识 :若n=a+b^10,(a<1,b∈N),则n的位数为b。
所以要求一个数字num有多少位,可以用(int)log10(num)+1,这样就求出num有多少位.
如果sum=n*(n-1)(n-2)……*1,那么log10(sum)=log10(n)+
log10(n-1)+…..+log10(2)+log10(1)。即sum的位数是
( int )( log10(n)+log10(n-1)+…..+log10(2)+log10(1) )+1。
(从小到大算)

下面这一种方法是程序外打表法,需要消耗时间。
还有一种是程序外打表,就是直接给复制,再导入,则肯定是0ms。

#include <stdio.h>
#include <math.h>

int a[10000010];
int main()
{
    double d;
    int i;
    int t;
    int n;
    for(i=1,d=0;i<10000005;i++){
        d+=log10(i);
        a[i]=(int)d+1;
    }

    scanf("%d",&t);
    while(t-->0){
        scanf("%d",&n);
        printf("%d\n",a[n]);

    }
    return 0;
}

还有一种方法:
利用Stirling公式. n!≈sqrt(2*pi*n)*[(n/e)^n]
n越大,答案越准确。
在n=1的情况下,也最大不过相差0.2.
这里只要计算位数,所以是可以用的。
此处的:
e ≈ 2.7182818284590452354, pi ≈ 3.141592653589793239;

#include<iostream>
#include<cmath>
using namespace std;
const double e = 2.7182818284590452354, pi = 3.141592653589793239;
double strling_digits_num(int n)
{
        return log10(2*pi*n)/2.0+n*(log10(n/e));
}

int main()
{
        int t;
        cin>>t;
        while(t--)
        {
                int n;
                cin>>n;
                double m=0;
                m=strling_digits_num(n);
                int answer=(int)m;
                answer++;
                cout<<answer<<endl;
        }
        return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

谙忆

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值