关闭

eclipse运行android工程时出现Unsupported major.minor version 52.0错误

标签: eclipseversion 52.0Unsupportedandroid
136人阅读 评论(0) 收藏 举报

最近在运行工程时意外出现Unsupported major.minor version 52.0的错误


具体现象是:eclipse编译是不报错的,但是在运行android工程时,在最后的lauching阶段时会弹出错误的提示窗口:


在网上搜的关于Unsupported major.minor version 52.0问题的解决方案都是建议修改jdk版本的,但是仔细想一想其实不是这个原因,因为jdk是用在eclipse上编译时使用的,上面我们说了,eclipse编译工程是不抛错的,因此不是IDE的原因;

而既然是在lauching阶段出现的问题,所以我满猜测是android自身进行的“第二次”编译出的错误,而这种错误是和android的SDK相关的,我突然回想起来我最近刚安装了最新版本(24)的Android SDK Build-Tools:


之后我把它给卸载了,果然就没有问题了!


我觉得原因应该是24版本的build-tools对jdk版本要求更高了(应该是8以上,因为我的电脑上的版本是7)

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:57015次
    • 积分:1237
    • 等级:
    • 排名:千里之外
    • 原创:50篇
    • 转载:92篇
    • 译文:2篇
    • 评论:11条
    联系我
    最新评论