Codeforces 919 D. Substring (记忆化搜索)

Description

You are given a graph with n nodes and m directed edges. One lowercase letter is assigned to each node. We define a path’s value as the number of the most frequently occurring letter. For example, if letters on a path are “abaca”, then the value of that path is 3. Your task is find a path whose value is the largest.

 

Input

The first line contains two positive integers n, m (1 ≤ n, m ≤ 300 000), denoting that the graph has n nodes and m directed edges.

The second line contains a string s with only lowercase English letters. The i-th character is the letter assigned to the i-th node.

Then m lines follow. Each line contains two integers x, y (1 ≤ x, y ≤ n), describing a directed edge from x to y. Note that x can be equal to y and there can be multiple edges between x and y. Also the graph can be not connected.

 

Output

Output a single line with a single integer denoting the largest value. If the value can be arbitrarily large, output -1 instead.

 

Examples input

5 4
abaca
1 2
1 3
3 4
4 5

 

Examples output

3

 

题意

在图中找一条路径,满足该路径上某字母的出现频率最高,输出该字母的出现次数。(图中可能存在自环以及重边)

 

思路

记忆化搜索, dp[o][ch] d p [ o ] [ c h ] 代表节点 o o 及以下字符 ch 出现的最大次数。

tarjan 判环,注意存在自环情况。

 

AC 代码

#include <bits/stdc++.h>
#define IO ios::sync_with_stdio(false);\
    cin.tie(0);\
    cout.tie(0);
using namespace std;
const int maxn = 3e5+10;
const int mod = 1e9+7;
typedef __int64 LL;
#define inf 0x7f7f7f

struct node
{
    int to;
    int next;
} edge[maxn];
int head[maxn],tot,dfn[maxn],low[maxn];
int dp[maxn][26],idx;
int ch[maxn],in[maxn];
bool instack[maxn];
int Stack[maxn],top;
int n,m;
bool flag;
char str[maxn];
void init()
{
    memset(dp,0,sizeof dp);
    memset(dfn,0,sizeof dfn);
    memset(low,0,sizeof low);
    memset(instack,false,sizeof instack);
    memset(head,-1,sizeof head);
    top = idx = tot = 0;
    flag = true;
}

void addedge(int u,int v)
{
    edge[tot].to = v;
    edge[tot].next = head[u];
    head[u] = tot++;
}

void dfs(int x)
{
    dfn[x] = low[x] = ++idx;
    instack[x] = true;
    Stack[top++] = x;
    for(int i=head[x]; i!=-1; i=edge[i].next)
    {
        int to = edge[i].to;
        if(!dfn[to])
        {
            dfs(to);
            low[x] = min(low[x],low[to]);
        }
        else if(instack[to] && dfn[to]<low[x])
            low[x] = dfn[to];
        for(int j=0; j<26; j++)
            dp[x][j] = max(dp[x][j],dp[to][j]);
    }
    if(dfn[x]==low[x])
    {
        int Size = 0,now;
        do
        {
            now = Stack[--top];
            instack[now] = false;
            ++Size;
        }
        while(now!=x);
        if(Size>1)
            flag = false;
    }
    if(!flag)
        return;
    ++dp[x][ch[x]];
}

void solve()
{
    for(int i=1; i<=n; i++)
        ch[i] = str[i-1] - 'a';
    int ans = -1;
    for(int i=1; i<=n; i++)
        if(in[i]==0)
        {
            dfs(i);
            for(int j=0; j<26; j++)
                ans = max(ans,dp[i][j]);
        }
    cout<<(flag?ans:-1)<<endl;
}

int main()
{
    IO;
    init();
    cin>>n>>m;
    cin>>str;
    for(int i=0; i<m; i++)
    {
        int u,v;
        cin>>u>>v;
        if(u==v)
            flag = false;
        ++in[v];
        addedge(u,v);
    }
    solve();
    return 0;
}
CodeForces - 616D是一个关于找到一个序列中最长的第k好子段的起始位置和结束位置的问题。给定一个长度为n的序列和一个整数k,需要找到一个子段,该子段中不超过k个不同的数字。题目要求输出这个序列最长的第k好子段的起始位置和终止位置。 解决这个问题的方法有两种。第一种方法是使用尺取算法,通过维护一个滑动窗口来记录\[l,r\]中不同数的个数。每次如果这个数小于k,就将r向右移动一位;如果已经大于k,则将l向右移动一位,直到个数不大于k。每次更新完r之后,判断r-l+1是否比已有答案更优来更新答案。这种方法的时间复杂度为O(n)。 第二种方法是使用枚举r和双指针的方法。通过维护一个最小的l,满足\[l,r\]最多只有k种数。使用一个map来判断数的种类。遍历序列,如果当前数字在map中不存在,则将种类数sum加一;如果sum大于k,则将l向右移动一位,直到sum不大于k。每次更新完r之后,判断i-l+1是否大于等于y-x+1来更新答案。这种方法的时间复杂度为O(n)。 以上是两种解决CodeForces - 616D问题的方法。具体的代码实现可以参考引用\[1\]和引用\[2\]中的代码。 #### 引用[.reference_title] - *1* [CodeForces 616 D. Longest k-Good Segment(尺取)](https://blog.csdn.net/V5ZSQ/article/details/50750827)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^koosearch_v1,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* [Codeforces616 D. Longest k-Good Segment(双指针+map)](https://blog.csdn.net/weixin_44178736/article/details/114328999)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^koosearch_v1,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值