关闭

最新安装cocoa pods错误提示

标签: Cocoa-pods
197人阅读 评论(0) 收藏 举报
分类:

RVM相关介绍:http://www.360doc.com/content/14/0526/11/14416931_381077569.shtml;
安装cocoa pods http://blog.csdn.net/qq_29284809/article/details/48446435;

最近在安装cocoapods提示一个错误信息,说需要安装Ruby version版本号要>= 2.2.2的;

这里写图片描述

解决办法:
– 1.查看我们ruby目前的版本号;

$ruby -v

这里写图片描述

– 2.安装Ruby版本管理器rvm;

$curl -L get.rvm.io | bash -s stable

这里写图片描述
– 3.解决上面安装rvm出现的提示信息;

$source ~/.bashrc
$source ~/.bash_profile

这里写图片描述

– 4.安装Ruby2.2.2的版本;

$rvm install 2.2.2

这里写图片描述
这里写图片描述

– 5.安装cocoa pods;

备注:苹果系统未升级以前使用命令
$sudo gem install cocoapods
备注:苹果系统升级 OS X EL Capitan 后改为以下命令(跟自己的系统而定)
$sudo gem install -n /usr/local/bin cocoapods
//查看pod安装路径
$which pod
如果路径不是显示/usr/local/bin/pod,在执行pod search命令搜索第三方时会搜索不出来;所以执行以下命令
$sudo gem install -n /usr/local/bin cocoapods

这里写图片描述
这里写图片描述

如果安装成功了,在执行pod search时搜不到相应的结果,执行该命令;

rm ~/Library/Caches/CocoaPods/search_index.json
删除成功后,再执行pod search命令;
0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:126329次
    • 积分:2075
    • 等级:
    • 排名:第18388名
    • 原创:80篇
    • 转载:20篇
    • 译文:0篇
    • 评论:23条
    最新评论