HDU1800 Flying to the Mars

题目链接:HDU1800

Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16008    Accepted Submission(s): 5144


Problem Description

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 
 

Input
Input file contains multiple test cases.  
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 

Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
  
  
4 10 20 30 04 5 2 3 4 3 4
 

Sample Output
  
  
1 2
 


题意:一堆士兵去坐飞行器到火星,要求必须由能力大的带能力小的并且最多带一个,可以像图中那样一个带一个,问最少需要多少个飞行器。

题目分析:由于同样大小的必须在两个不同的飞行器上,所以最少带多少取决于最多的数字重复次数。由于每个数最大30位所以可以用数组存储能力值,插入字典树同时在插入的串尾做标记统计同样字出现次数。只要插入一遍就可以把最大值算出来。

//
//  main.cpp
//  HDU1800
//
//  Created by teddywang on 16/4/1.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef struct node{
    int num;
    node *next[10];
}trienode;
trienode *root;
int maxn,n;
void insert(char *t)
{
    trienode *r=root,*h;
    int len=strlen(t);
    for(int i=0;i<len;i++)
    {
        int buf=t[i]-'0';
        if(r->next[buf]==NULL)
        {
            h=new node;
            h->num=0;
            for(int j=0;j<10;j++)
                h->next[j]=NULL;
            r->next[buf]=h;
            r=h;
        }
        else r=r->next[buf];
    }
    r->num++;
    if(r->num>maxn)
        maxn=r->num;
}

void del(trienode *r)
{
    for(int i=0;i<10;i++)
    {
        if(r->next[i]!=NULL)
            del(r->next[i]);
    }
    free(r);
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
        {
            printf("1\n");
            continue;
        }
        maxn=0;
        root=new node;
        root->num=0;
        for(int i=0;i<10;i++)
            root->next[i]=NULL;
        for(int i=0;i<n;i++)
        {
            char s[35];
            scanf("%s",s);
            int l=strlen(s),j;
            for(j=0;j<l-1;j++)
            {
                if(s[j]!='0') break;
            }
            insert(s+j);
        }
        printf("%d\n",maxn);
        del(root);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值