HDU1907 John Nim游戏

20 篇文章 0 订阅

题目链接:HDU1907

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4425    Accepted Submission(s): 2531


Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 

Sample Input
  
  
2 3 3 5 1 1 1
 

Sample Output
  
  
John Brother
 

题意:一堆不同颜色的M&M糖,2个人轮流吃,一次只能吃若干颗相同颜色的糖,吃完最后一块的输,问谁会赢。

题目分析:这是取完的人判为输的Nim游戏,有专门的结论,设所有堆个数异或为0是T态,反之为S态。设单堆个数多于1个为充裕堆,充裕堆多于1个为2态,其余为1和0态。这里S2,S1,T0态都是必胜态,因此只需判断初始状态是什么状态即可。

//
//  main.cpp
//  HDU1907
//
//  Created by teddywang on 2016/8/29.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int T,n,a[100];
    cin>>T;
    while(T--)
    {
        cin>>n;
        int ans=0,flag=0;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
            if(a[i]>1) flag++;
            ans^=a[i];
        }
        if((flag>=1&&ans!=0)||(flag==0&&ans==0))
            cout<<"John"<<endl;
        else cout<<"Brother"<<endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值