HDOJ 5616-Jam's balance【模拟】

Jam's balance

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 188    Accepted Submission(s): 82


Problem Description
Jim has a balance and N weights. (1N20)
The balance can only tell whether things on different side are the same weight.
Weights can be put on left side or right side arbitrarily.
Please tell whether the balance can measure an object of weight M.
 

Input
The first line is a integer T(1T5) , means T test cases.
For each test case :
The first line is N , means the number of weights.
The second line are N number, i'th number wi(1wi100) means the i'th weight's weight is wi .
The third line is a number M . M is the weight of the object being measured.
 

Output
You should output the "YES"or"NO".
 

Sample Input
  
  
1 2 1 4 3 2 4 5
 

Sample Output
  
  
NO YES YES
Hint
For the Case 1:Put the 4 weight alone For the Case 2:Put the 4 weight and 1 weight on both side
 

Source
 解题思路:
这道题和杭电的1709是一样的,就是 砝码可以放在天枰的左右两端。
#include<stdio.h>  
#include<math.h>  
#include<string.h>
#include<stdlib.h>  
  
int c1[30000],c2[30000];  
int a[30000];  
bool cc[30000];
  
int main()  
{  
    int i,j,n,sum; 
    int nn; 
    scanf("%d",&nn);
    while(nn--)  
    {  
        scanf("%d",&n);
        sum=0;  
        for(i=1;i<=n;i++)  
        {  
            scanf("%d",&a[i]);  
            sum=sum+a[i];  
        }  
        for(i=0;i<=sum;i++)  
        {  
            c1[i]=0;  
            c2[i]=0;  
        }  
        c1[0]=1;  
        for(i=1;i<=n;i++)  
        {  
            for(j=0;j+a[i]<=sum;j++)  
            {  
                if(c1[j]==1)  
                {  
                    c2[j]=1;  
                    c2[j+a[i]]=1;  
                    c2[abs(j-a[i])]=1;  
                }  
            }  
            for(j=0;j<=sum;j++)  
            {  
                c1[j]=c2[j];  
                c2[j]=0;  
            }  
        }  
        int num=0;  
        memset(cc,false,sizeof(cc));
        for(i=1;i<=sum;i++)  
        {  
            if(c1[i]==0)  
            {
                cc[i]=true;
            } 
        }  
        int wnm;
        scanf("%d",&wnm);
        while(wnm--)
        {
            int yyy;
            scanf("%d",&yyy);
            if(yyy>sum)
            {
                printf("NO\n");
                continue;
            }
            if(cc[yyy]==true)
            {
                printf("NO\n");
            }
            else
            {
                printf("YES\n");
            }
        }
    }  
    return 0;  
}  



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值