poj--2186--Popular Cows (scc+缩点)

Popular Cows

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 1
Problem Description
Every cow's dream is to become the most popular cow in the herd. In a herd of N (1 <= N <= 10,000) cows, you are given up to M (1 <= M <= 50,000) ordered pairs of the form (A, B) that tell you that cow A thinks that cow B is popular. Since popularity is transitive, if A thinks B is popular and B thinks C is popular, then A will also think that C is
popular, even if this is not explicitly specified by an ordered pair in the input. Your task is to compute the number of cows that are considered popular by every other cow.
 

Input
* Line 1: Two space-separated integers, N and M

* Lines 2..1+M: Two space-separated numbers A and B, meaning that A thinks B is popular.
 

Output
* Line 1: A single integer that is the number of cows who are considered popular by every other cow.
 

Sample Input
  
  
3 3 1 2 2 1 2 3
 

Sample Output
  
  
1
/*找出最受欢迎的牛*/
#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
using namespace std;
#define MAX 50010
struct node
{
	int u,v;
	int next;
}edge[MAX];
int low[MAX],dfn[MAX];
int sum,sumin,sumout;
int sccno[MAX],scc_cnt;
int head[MAX],dfs_clock,cnt;
bool Instack[MAX];
vector<int>G[MAX];
vector<int>scc[MAX];
stack<int>s;
int in[MAX],out[MAX];
int m,n;
void init()
{
	memset(head,-1,sizeof(head));
	cnt=0;
}
void add(int u,int v)
{
	edge[cnt].u=u;
	edge[cnt].v=v;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
void getmap()
{
	int a,b;
	while(m--)
	{
		scanf("%d%d",&a,&b);
		add(a,b);
	}
}
void tarjan(int u,int fa)
{
	int v;
	low[u]=dfn[u]=++dfs_clock;
	s.push(u);
	Instack[u]=true;
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		v=edge[i].v;
		if(!dfn[v])
		{
			tarjan(v,u);
			low[u]=min(low[u],low[v]);
		}
		else if(Instack[v])
		low[u]=min(low[u],dfn[v]);
	}
	if(low[u]==dfn[u])
	{
		scc_cnt++;
		scc[scc_cnt].clear();
		for(;;)
		{
			v=s.top();
			s.pop();
			Instack[v]=false;
			scc[scc_cnt].push_back(v);
			sccno[v]=scc_cnt;
			if(u==v) break;
		}
	}
}
void find(int l,int r)
{
	memset(low,0,sizeof(low));
	memset(dfn,0,sizeof(dfn));
	memset(sccno,0,sizeof(sccno));
	memset(Instack,false,sizeof(Instack));
	scc_cnt=dfs_clock=0;
	for(int i=l;i<=r;i++)
	if(!dfn[i])
	tarjan(i,-1);
}
void suodian()
{
	for(int i=1;i<=scc_cnt;i++)
	G[i].clear(),in[i]=0,out[i]=0;
	for(int i=0;i<cnt;i++)
	{
		int u=sccno[edge[i].u];
		int v=sccno[edge[i].v];
		if(v!=u)
		{
			G[u].push_back(v);
			out[u]++,in[v]++;
		}
	}
}
void solve()
{
	int sum=0;
	int ans=0;
	for(int i=1;i<=scc_cnt;i++)
	{
		if(out[i]==0)
		//出度为零说明在新图里他是叶子节点,现在统计叶子节点个数 
		{
			sum++;
			ans+=scc[i].size();
		}
	}
	if(sum>1) printf("0\n");
	if(sum==0) printf("%d\n",n);
	//如果只有1个scc,说明全部的牛都是最受欢迎的 
	if(sum==1) printf("%d\n",ans);
	//如果sum==0说明在新图里叶子节点只有一个
	//那么当前的scc中所有的牛都是最受欢迎的 
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		init();
		getmap();
		find(1,n);
		suodian();
		solve();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值