hdoj--3072--Intelligence System(scc+缩点+数据去重)

Intelligence System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1988    Accepted Submission(s): 859


Problem Description
After a day, ALPCs finally complete their ultimate intelligence system, the purpose of it is of course for ACM ... ...
Now, kzc_tc, the head of the Intelligence Department (his code is once 48, but now 0), is sudden obtaining important information from one Intelligence personnel. That relates to the strategic direction and future development of the situation of ALPC. So it need for emergency notification to all Intelligence personnel, he decides to use the intelligence system (kzc_tc inform one, and the one inform other one or more, and so on. Finally the information is known to all).
We know this is a dangerous work. Each transmission of the information can only be made through a fixed approach, from a fixed person to another fixed, and cannot be exchanged, but between two persons may have more than one way for transferring. Each act of the transmission cost Ci (1 <= Ci <= 100000), the total cost of the transmission if inform some ones in our ALPC intelligence agency is their costs sum.
Something good, if two people can inform each other, directly or indirectly through someone else, then they belong to the same branch (kzc_tc is in one branch, too!). This case, it’s very easy to inform each other, so that the cost between persons in the same branch will be ignored. The number of branch in intelligence agency is no more than one hundred.
As a result of the current tensions of ALPC’s funds, kzc_tc now has all relationships in his Intelligence system, and he want to write a program to achieve the minimum cost to ensure that everyone knows this intelligence.
It's really annoying!
 

Input
There are several test cases.
In each case, the first line is an Integer N (0< N <= 50000), the number of the intelligence personnel including kzc_tc. Their code is numbered from 0 to N-1. And then M (0<= M <= 100000), the number of the transmission approach.
The next M lines, each line contains three integers, X, Y and C means person X transfer information to person Y cost C.
 

Output
The minimum total cost for inform everyone.
Believe kzc_tc’s working! There always is a way for him to communicate with all other intelligence personnel.
 

Sample Input
  
  
3 3 0 1 100 1 2 50 0 2 100 3 3 0 1 100 1 2 50 2 1 100 2 2 0 1 50 0 1 100
 

Sample Output
  
  
150 100 50
#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
using namespace std;
#define MAX 500100
#define INF 0x3f3f3f
struct node
{
	int u,v,val;
	int next;
}edge[MAX];
int low[MAX],dfn[MAX];
int head[MAX],scc_cnt,dfs_clock,cnt;
int in[MAX],out[MAX],dp[MAX];
int sccno[MAX];
int m,n;
bool Instack[MAX];
vector<int>G[MAX];
vector<int>scc[MAX];
stack<int>s;
void init()
{
	memset(head,-1,sizeof(head));
	cnt=0;
}
void add(int u,int v,int val)
{
	int i;
	for( i=head[u];i!=-1;i=edge[i].next)
	{
		if(edge[i].v==v) 
		break;
	}
	if(i==-1)
	{
		edge[cnt].u=u;
		edge[cnt].v=v;
		edge[cnt].val=val;
		edge[cnt].next=head[u];
		head[u]=cnt++;
	}
	else 
	edge[i].val=min(edge[i].val,val);
}
void getmap()
{
	int a,b,c;
	while(m--)
	{
		scanf("%d%d%d",&a,&b,&c);
		add(a,b,c);
	}
}
void tarjan(int u,int fa)
{
	int v;
	low[u]=dfn[u]=++dfs_clock;
	Instack[u]=true;
	s.push(u);
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		v=edge[i].v;
		if(!dfn[v])
		{
			tarjan(v,u);
			low[u]=min(low[u],low[v]);
		}
		else if(Instack[v])
		low[u]=min(low[u],dfn[v]);
	}
	if(low[u]==dfn[u])
	{
		scc_cnt++;
		for(;;)
		{
			v=s.top();s.pop();
			Instack[v]=false;
			sccno[v]=scc_cnt;
			if(v==u) break;
		}
	}
}
void find(int l,int r)
{
	memset(sccno,0,sizeof(sccno));
	memset(low,0,sizeof(low));
	memset(dfn,0,sizeof(dfn));
	memset(Instack,false,sizeof(Instack));
	scc_cnt=dfs_clock=0;
	for(int i=l;i<=r;i++)
	if(!dfn[i])
	tarjan(i,-1);
}
void suodian()
{
	for(int i=1;i<=scc_cnt;i++)
	G[i].clear(),dp[i]=INF;
	for(int i=0;i<cnt;i++)
	{
		int u=sccno[edge[i].u];
		int v=sccno[edge[i].v];
		if(u!=v)
		{
			G[u].push_back(v);
			dp[v]=min(dp[v],edge[i].val);
		}
	}
}
void solve()
{
	int sum=0;
	for(int i=1;i<=scc_cnt;i++)
	{
		if(sccno[0]!=i)
		sum+=dp[i];
	}
	printf("%d\n",sum);
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		init();
		getmap();
		find(0,n-1);
		suodian();
		solve();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值