动态规划之快速幂 CSU - 1198 Staginner the Caster

Description

Staginner , a wise coder , became a legendary soul after centuries later somehow . So one day he was summoned by a sorcerer , Gestapolur . The sorcerer said : I'm facing a hard problem and it's so obscure that even make me wanna going to die . So I summoned you for help.

The problem was described as following:

There are N(1<=N<=231-1) magic grails , each grail could have none or several magic properties . And there are K(1<=K<=N) magic properties .We supposed that all grails have property i are belong to set S_i . And because some mysterious reason , S1 ∩ S2 ∩ ... ∩ Smust be empty. So how many grail-arrange scheme could satisfy these condition ?

Input

The input contains multiple cases, each case have 2 integers in one line represent n and k(1 <= k <= n <= 231-1), proceed to the end of the file.

Output

Output the total number mod 1000000007.

Sample Input

1 1
2 2

Sample Output

1
9

思路:根据题意符合条件的情况有:种。

          但是N非常非常的大,所以先求C=,然后求C的平方就可以了。

代码:

#include<iostream>
using namespace std;
#define MO 1000000007
int fab(int a,int b) //a^b%1000000007
{
	if (b==1) return a;
	
	long long c = fab(a, b / 2);//fab(a, b / 2)*fab(a, b / 2) % MO
	c = c*c%MO;
	c = (b % 2 == 1) ? c*a%MO : c;
	return c;
	
}
int main()
{
	int n, k;
	while (cin >> n >> k)
	{
		int kk = fab(2, k) - 1;
		cout << fab(kk, n) << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值