03-树2 List Leaves (25分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NN (\le 10≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N-1N−1. Then NN lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:

4 1 5


AC代码如下:

#include <iostream>
#include <vector>
#include <queue>
using namespace std;

struct Node{
    int data;
    int left;
    int right;
};

//建树函数,返回根节点 
int BuildTree(vector<struct Node> &Tree,int N){
    int root = -1;
    char left,right;
    vector<int> check(N,0);

    for ( int i = 0 ; i < N ; i++){
        cin>>left>>right;
        Tree[i].data = i;
        //判断左子树是否为空,不为空则把ckeck数组相应位置1,否则置-1 
        if ( left != '-'){
            Tree[i].left = (int)(left-'0');
            check[Tree[i].left] = 1;
        }else{
            Tree[i].left = -1;
        }
        //判断右子树是否为空,不为空则把ckeck数组相应位置1,否则置-1 
        if ( right != '-'){
            Tree[i].right = (int)(right-'0');
            check[Tree[i].right] = 1;
        }else{
            Tree[i].right = -1;
        }
    }

    //寻找根节点的索引 
    for ( int i = 0 ; i < N ; i++){
        if ( check[i] == 0){
            root = i;
            break;
        }
    }
    return root;
} 

//寻找叶子节点函数
vector<int> Find_Leaves(vector<struct Node> &Tree,int root)
{
    vector<int> leaves;
    queue<struct Node> que;
    struct Node treenode;
    if ( root == -1){
        return {};
    }else{
        que.push(Tree[root]);
        while(!que.empty()){
            treenode = que.front();
            que.pop();
            if ( treenode.left == -1 && treenode.right == -1){
                leaves.push_back(treenode.data);
            }
            if ( treenode.left != -1){
                que.push(Tree[treenode.left]);
            }
            if ( treenode.right != -1){
                que.push(Tree[treenode.right]);
            }
        }
    }
    return leaves;
}

void Print(vector<int> & leaves)
{
    cout<<leaves[0];
    for ( int i = 1 ; i < leaves.size() ; i++){
        cout<<" "<<leaves[i];
    }
}

int main()
{
    int N;//树节点的个数 
    cin>>N;
    vector<struct Node> Tree(N); //存储树结点的数组 

    //完成建树过程,返回根节点索引
    int root = BuildTree(Tree,N);

    //寻找叶子结点数组 
    vector<int> leaves = Find_Leaves(Tree,root);

    //打印所有叶子结点 
    Print(leaves);

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

daipuweiai

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值