POJ-3356 AGTC(编辑距离)

AGTC
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12609 Accepted: 4748

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct

Certainly, we would like to minimize the number of all possible operations.

Illustration

A G T A A G T * A G G C

| | |       |   |   | |

A G T * C * T G A C G C

Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A  G  T  A  A  G  T  A  G  G  C

|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4

Source

题解:一个求编辑距离的题目,编辑距离就是经过增,删,改3种操作把字符串x变成字符串y,要求求出最小的操作次数.
设2个字符串为S,T.dp[i][j]是当匹配到S[i]和T[j]时需要的操作次数,那么就有4种情况
(1) S,T对应位置都是普通字符,相同,无操作
(2) S,T对应位置都是普通字符,不同,T修改
(3) S在该位置是特殊字符,T在该位置是普通字符,T删除
(4) S在该位置是普通字符,T在该位置是特殊字符,T增加
对应的对齐的情况
(1) 必须S[i]==T[j],这时前i–1和j–1位都已经对齐了,这种情况下最少操作数是dp[i-1][j-1]
(2) S[i]≠T[j]这时前i–1和j–1位都已经对齐了这种情况下最少操作数是dp[i-1][j-1]+1
(3) S的前i位和T的前(j–1)位已经对齐了这种情况下最少操作数是dp[i][j-1]+1

(4) S的前(i-1)位已经和T的前j位对齐了,这种情况下最少操作数是dp[i-1][j]+1

#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
char st1[1005],st2[1005];
int dp[1005][1005];
int main(){
    int len1,len2;
   // freopen("in.txt","r",stdin);
    while(~scanf("%d",&len1)){
        scanf("%s%d%s",st1,&len2,st2);
        memset(dp,0x3f,sizeof(dp));
        for(int i=len1;i>0;i--) st1[i]=st1[i-1];
        for(int i=len2;i>0;i--) st2[i]=st2[i-1];
        for(int i=0;i<=len1;i++) dp[i][0]=i;
        for(int i=0;i<=len2;i++) dp[0][i]=i;
        for(int i=1;i<=len1;i++){
            for(int j=1;j<=len2;j++){
                if(st1[i]==st2[j]) dp[i][j]=dp[i-1][j-1];
                dp[i][j]=min(dp[i][j],dp[i-1][j]+1);//²åÈë
                dp[i][j]=min(dp[i][j],dp[i][j-1]+1);//ɾ³ý
                dp[i][j]=min(dp[i][j],dp[i-1][j-1]+1);//ÐÞ¸Ä
            }
        }
        printf("%d\n",dp[len1][len2]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值