关闭

Can't locate Switch.pm in @INC

31人阅读 评论(0) 收藏 举报

  the perl version (5.14) shipped with 12.10 does not include the Switch.pm module needed while building WebKiT-GTK.

How to install Perl Switch.pm module required to build WebKit-GTK?

  If you want to install the Switch.pm Perl module into your system Perl config, there are two methods of installing it:

  1. Install it through the Ubuntu repositories.
  2. Install the .pm through CPAN.

  At this time, both will provide the current version of this module(2.16).

Installing Switch.pm using the Ubuntu repositories:

  • From the command-line, the installation can be completed by running the following command from the terminal (Ctrl-Alt-t):
  • sudo apt-get install libswitch-perl
    • Within Synaptic, right-click on the libswitch-perl package, select Mark for installation, then click on the Apply button.
    • Within the Ubuntu Software Center (USC), search for the phrase libswitch-perl, highlight the package and select install:

Installing Switch.pm using CPAN:

  If you would prefer to install this via cpan, follow these instructions:

  • Open a terminal(Ctrl-Alt-t).
  • Enter the command cpan.
  • At the prompt cpan[1]>, type install Switch.
  • Once completed, Type exit.

  The Switch.pm Perl module will now be available for you to use in your scripts.

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:32次
    • 积分:2
    • 等级:
    • 排名:千里之外
    • 原创:0篇
    • 转载:1篇
    • 译文:0篇
    • 评论:0条
    文章存档