Gradle sync failed: Plugin is too old, please update to a more recent version

原创 2016年08月30日 16:12:02

一、概述

在使用Android Studio过程中,有时候会遇到标题中的异常,主要原因是在项目中的gradle.properties中依赖包版本过低。


解决办法:最简单的方式就是查找最新版本的jar包,并且修改为最新版本,然后系统会自动下载。


二、步骤

1、关于最新jar包,可以查看如下地址:http://tools.android.com/tech-docs/new-build-system



2、最上面2.2.0-beta2即为最新的版本。这时候需要注意的是,如果你在第一个图片中手动去修改并点击右上角的“try again”,有可能会继续出现一个gradle版本过低的错误。


主要原因应该是就这个jar需要更高版本的gradle支持它。


3、你需要去【File】-【Project Structure】或者按Ctrl+alt+shift+s快捷键,打开项目结构,点击第二个Project,把第一项“Gradle Version”和第二项“Android Plugin Version”分别设置为下面的值。



4、重新编译,成功。




版权声明:本文为博主原创文章,未经博主允许不得转载。

关于android studio出现Gradle sync failed: Plugin is too old, please update to a more recent version

今天打开as出现以下错误信息: Gradle sync failed: Plugin is too old, please update to a more recent version,or ...

Error:(1, 0) Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRID

转载
  • gjy211
  • gjy211
  • 2016年03月07日 15:04
  • 963

The android gradle plugin version 2.3.0-alpha1 is too old, please update to the latest version.解决办法

MAC The android gradle plugin version 2.3.0-alpha1 is too old, please update to the latest version.解...
  • callzjy
  • callzjy
  • 2016年12月24日 02:44
  • 8891

This version of the rendering library is more recent than your version of ADT plug-in. Please update

最近使用 Help --> Check for Updates 升级了Eclipse部分插件,之后新建4.3的工程,res/layout 下的xml布局文件无法预览了, 一预览总是报这个错: ...

Plugin is too old,gradle版本不兼容问题!

首先清楚是驱动插件 gradle 与环境变量 classpath即Android Plugin 不融合错误, 好比一个是 驱动 一个是API , 驱动插件老的 配 API老的也能用。 驱动插...

the rendering library is more recent than your version of android studio

最近更新了自己Android Studio中的SDK到最新版本,AS的一部分配置修改了。 然后 在打开布局文件的时候 会出现 渲染错误 Rendering problem the render...

Version of activiti database (5.15.1) is more recent than the engine (5.14)

org.activiti.engine.ActivitiException: Version of activiti database (5.15.1) is more recent than the...

"A more recent version of this document is supported by this" JPA persistence.xml问题

问题解决处:感谢stackoverflowhttp://stackoverflow.com/questions/3701901/eclipse-does-not-recognize-content-o...

ORA-01122 database file 1 failed verification check,ORA-01207: file is more recent than control file

数据库强制关闭却无法启动,报错ORA-01222,ORA-01207
  • robo23
  • robo23
  • 2014年09月27日 21:10
  • 1760

《Plugin is too old 理解及相应的处理》

ButterKnife 8.4.0 注释使用及快捷插件安装级使用
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Gradle sync failed: Plugin is too old, please update to a more recent version
举报原因:
原因补充:

(最多只允许输入30个字)