hdu2056 Rectangles

Rectangles

 

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21958    Accepted Submission(s): 7147

 

 

Problem Description

Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

 

 

Input

Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

 

 

Output

Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

 

 

Sample Input

 

1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00 5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

 

 

Sample Output

 

1.00 56.25

 

 

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;

int main()
{
	double x1,y1,x2,y2,x3,y3,x4,y4;
	while(cin>>x1>>y1>>x2>>y2>>x3>>y3>>x4>>y4)
	{
		double area=0.00;
		//输入的2个对角点顺序是随机的,左上-右下,右下-左上,右上-左下 左下-右上
		if(x2<x1)swap(x1,x2);
		if(y2<y1)swap(y1,y2);
		if(x4<x3)swap(x3,x4);
		if(y4<y3)swap(y3,y4);//变换为 左下-右上(即x1<x2,x3<x4,y1<y2,y3<y4) 
				
	    double lx,rx,ly,ry;
	    lx=max(x1,x3); rx=min(x2,x4); //计算X轴上的左端的较大值,右端的较小值
        ly=max(y1,y3); ry=min(y2,y4); //计算y轴上的下端的较大值,上端的较小值
        if(lx<=rx&&ly<=ry)
		{                   //公共矩形的左端不能超过右端,下端不能超上端
          area=1.0*(rx-lx)*(ry-ly);   //计算答案
          printf("%.2lf\n",area);
        }
        else printf("0.00\n"); //没有公共区间,输出0.00
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值