HDU 5832 A water problem(简单思维题目)【2016中国大学生程序设计竞赛 - 网络选拔赛】

109 篇文章 0 订阅
39 篇文章 0 订阅

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5832

A water problem

Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1197 Accepted Submission(s): 560

Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input
There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

Output
For the i-th test case, output Case #i: , then output “YES” or “NO” for the answer.

Sample Input
10001
0
333

Sample Output
Case #1: YES
Case #2: YES
Case #3: NO

Author
UESTC

Source
2016中国大学生程序设计竞赛 - 网络选拔赛

【题目意思】给你一个数,问你它是不是137和73的倍数。
【题目分析】137和73的最小公倍数是10001,然后问题就转化为问这个数是不是10001的倍数,接下来就简单了。

下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

char a[10000005];
int main()
{
    int kase=0;
    while(~scanf("%s",a))
    {
        int sum=0;
        for(int i=0;a[i]!='\0';i++)
        {
            sum=(sum*10+a[i]-'0')%10001;
        }
        if(sum==0)
        {
            printf("Case #%d: YES\n",++kase);
        }
        else
        {
            printf("Case #%d: NO\n",++kase);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值