Sicily1201——01000001

1201. 01000001

限制条件

时间限制: 1 秒, 内存限制: 32 兆

题目描述

Adding binary numbers is a very simple task, and very similar to the longhand addition of decimal numbers. As with decimal numbers, you start by adding the bits (digits) one column at a time, from right to left. Unlike decimal addition, there is little to memorize in the way of rules for the addition of binary bits:

   0 + 0 = 0 
   1 + 0 = 1 
   0 + 1 = 1 
   1 + 1 = 10 
   1 + 1 + 1 = 11

Just as with decimal addition, when the sum in one column is a two-bit (two-digit) number, the least significant figure is written as part of the total sum and the most significant figure is ``carried" to the next left column. Consider the following examples:

                       11  1 <-- Carry bits --> 1   11 
  1001101             1001001                    1000111 
+ 0010010           + 0011001                  + 1010110 
 --------           ---------                  ---------
  1011111             1100010                   10011101

The addition problem on the left did not require any bits to be carried, since the sum of bits in each column was either 1 or 0, not 10 or 11. In the other two problems, there definitely were bits to be carried, but the process of addition is still quite simple.

输入格式

The first line of input contains an integer N,(1<=N<=1000),which is the number of binary addition problems that follow. Each problem appears on a single line containing two binary values separated by a single space character. The maximum length of each binary value is 80 bits (binary digits). Note: The maximum length result could be 81 bits (binary digits).

输出格式

For each binary addition problem, print the problem number, a space, and the binary result of the addition. Extra leading zeroes must be omitted.

样例输入

3 
1001101 10010 
1001001 11001 
1000111 1010110

样例输出

1 1011111 
2 1100010 
3 10011101

这题要求写出二进制的加法,我的做法跟高精度加法有点相似,还有一个坑是输出字符串的时候,要求出去开始部分多余的0

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <iomanip>
#include <map>
#include <vector>
#include <cmath>
#include <string>
#include <set>
#include <sstream>
#include <cstring>

using namespace std;

string add(string num1,string num2)
{
	int l1 = num1.size(),l2 = num2.size(),l;
	if(l1 > l2)
	{
		string a(l1-l2,'0');
		num2 = a+num2;
		l = l1;
	}
	else if(l2 > l1)
	{
		string a(l2-l1,'0');
		num1 = a+num1;
		l = l2;
	}
	else l = l1;
	
	string res;
	bool up = 0;
	int x;char z;
	for(int i = l-1;i>=0;i--)
	{
		x = num1[i]-'0'+num2[i]-'0';
		if(up){x += 1;up = 0;}else {up = 0;}
		if(x>1) up = 1;
		z = x%2 + '0';
		res = z+res;
		
		//cout <<"res: "<<res<<endl;
	}
	if(up) res = '1'+res;
	return res;
}

void print(string num)
{
	int cnt = 0;
	for(int i = 0; i<num.size(); i++)
	{
		if(num[i] == '0') cnt++;
	}
	if(cnt == num.size())
	{
		cout << '0' << endl;
		return;
	}
	
	int i;
	for(i = 0;i < num.size(); i++)
		if(num[i] != '0') break;
	for(;i<num.size();i++)
		cout << num[i];
	cout << endl;
}

int main()
{
	int n;
	cin >> n;
	for(int i = 1; i<=n; i++)
	{
		string num1,num2;
		cin >> num1 >> num2;
		cout << i <<" ";
		string res = add(num1,num2);
		print(res);
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值