HDU 3709 Balanced Number (数位DP)

                                                                                                           Balanced Number             
Time Limit: 5000MS                             Memory Limit: 65535KB 64bit IO Format:                            %I64d & %I64u                        

                                         Status                                                 

Description

  A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job  
to calculate the number of balanced numbers in a given range [x, y]. 

Input

The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10  18).

Output

For each case, print the number of balanced numbers in the range [x, y] in a line.

Sample Input

2
0 9
7604 24324

Sample Output

10
897

Hint

Source

 
题意:在区间中输出满足条件数的个数(条件:对一个数,如果它左右两边的是平衡的,例4139,以3为支点,左面 4*2+1=9,右面9,左右相等)
题解:数位DP,dp[i][j][k],当前位置为i,支点为j,k为左右两边的和(假设左正右负)。
我们枚举支点即可,一个优化,由于是从左往右的,sum的值不能小于0,
代码:
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define ll long long
using namespace std;
ll dp[30][30][1650];
int a[30];
ll dfs(int pos,int p,int sum,bool limit)
{
    if(pos==0)
        return sum==0;
    if(sum<0)
        return 0;
    if(!limit&&dp[pos][p][sum]!=-1)
        return dp[pos][p][sum];
    int up=limit?a[pos]:9;
    ll ans=0;
    for(int i=0;i<=up;i++)
    {
        ans+=dfs(pos-1,p,sum+i*(pos-p),limit&&i==a[pos]);
    }
    if(!limit)
        dp[pos][p][sum]=ans;
    return ans;
}
ll solo(ll x)
{
    if(x==-1)
        return 0;
        int pos=0;
    while(x)
    {
        a[++pos]=x%10;
        x/=10;
    }
    ll ans=0;
    for(int i=1;i<=pos;i++)
        ans+=dfs(pos,i,0,true);
    return ans-pos+1;
}
int main()
{
    int t;
    cin>>t;
    memset(dp,-1,sizeof(dp));
    while(t--)
    {
        ll l,r;
        cin>>l>>r;
        cout<<solo(r)-solo(l-1)<<endl;
    }

}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值