(约瑟夫环公式)Joseph - HDOJ

Joseph

Problem Description
The Joseph\\\\’s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, …, n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

        The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input
3
4
0

Sample Output
5
30

Source
ACM暑期集训队练习赛(5)

Recommend
lcy

总结:
利用数学规律来做,约瑟夫环的递推公式
F(n) = (F(n-1) + m) % t
可以算出地n次出局的人,t为目前的总人数
这道题的思路就是出局K个人,这K个人里面不能是前K个人里面的
,如果出局的K个人全部都是题意要求出局的人,那么 m 就是我们
要找的值.

在代码中的约瑟夫环公式是F(n) = (F(n-1) + (m-1)) % t
因为m的值可能要比t值大,这样结果可能会出现零,而我们的环里面并没有零这个位置,所以要调整一下,将我们的环调整为0 – 2k-1
,相应的m要减去1,这样,就可以避免处理余数为零的步骤

#include<iostream>
#include<stdio.h>

using namespace std;

int ans[15];

void table()
{
    for(int k=1; k<=13; ++k)
    {
        for(int m=k+1; ;m++)
        {
            int x=0,j,len=2*k;
            for(j=0; j<k; ++j)
            {
                x = (x+ (m-1) ) % (len-j);
                if(x < k)
                    break;
            }
            if(j == k)
            {
                ans[k] = m;
                break;
            }
        }
    }
}
int main(void)
{
    table();
    int n;
    while(scanf("%d",&n) && n)
    {
        cout << ans[n]<<endl;
    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值