poj2395 Out of Hay(最小生成树)

Out of Hay
Time Limit: 1000MS Memory Limit: 65536K
T  

Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry. 

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M. 

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43

Hint

OUTPUT DETAILS: 

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

题意:

有n个农场,m条路,要走遍n个农场,每走一条路要喝边权数量的水,到了另一个农场可以补充水源,那么即求最小生成树中最大的边权。


思路:

prim算法求最小生成树中最大边权。并且不需要特判一些特殊情况。模板题了,1Y


代码:

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstring>
#include <cstdio>

using namespace std;
const int INF = 0x3f3f3f3f;

struct Edge
{
	int to, w;
};

class Graph
{
public:
	int n;
	bool *vis;
	int *dist;
	vector<Edge> *edges;
	Graph(int _n){
		n = _n;
		vis = new bool[n];
		dist = new int[n];
		edges = new vector<Edge>[n];
		memset(vis, false, n*sizeof(bool));
		memset(dist, 0x3f, n*sizeof(int));
	}
	~Graph(){
		delete []vis;
		delete []dist;
		delete []edges;
	}

	void Insert(int x, int y, int w){
		edges[x].push_back(Edge{y, w});
		edges[y].push_back(Edge{x, w});
	}

	void prim(int s){
		int ans = -1;
		dist[s] = 0;
		for(int i=0; i<n; i++){
			int min_dist = INF, tag;
			for(int j=0; j<n; j++){
				if(!vis[j] && dist[j]<min_dist){
					min_dist = dist[j];
					tag = j;
				}
			}
			vis[tag] = true;
			ans = max(ans, min_dist);
			vector<Edge>::iterator it;
			for(it=edges[tag].begin(); it!=edges[tag].end(); it++){
				if(!vis[it->to] && it->w < dist[it->to])
					dist[it->to] = it->w;
			}
		}
		printf("%d\n", ans);
	}
};

int main(){
	int n, m, a, b, w;
	while(scanf("%d%d", &n, &m)!=EOF){
		Graph g(n);
		for(int i=0; i<m; i++){
			scanf("%d%d%d", &a, &b, &w);
			g.Insert(a-1, b-1, w);
		}
		g.prim(0);
	}
	return 0;
}


附上一个优先队列的写法:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <vector>
#include <algorithm>

using namespace std;

const int MAXN = 2000 + 15;
const int INF = 0x3f3f3f3f;
int n, m, a, b, c;

struct Node
{
	int tag, dist;
	Node(){}
	Node(int tag, int dist):tag(tag), dist(dist){}
	bool operator<(const Node& rhs)const{
		return dist>rhs.dist;
	}
};

vector<Node> edges[MAXN];
bool vis[MAXN];

void init(){
	for(int i=0; i<n+10; ++i){
		edges[i].clear();
	}
	memset(vis, 0, sizeof(vis));
}



int prim(){
	int ans = 0;
	priority_queue<Node> q;
	q.push(Node(a, 0));
	while(!q.empty()){
		Node tmp = q.top(); q.pop();
		int tag = tmp.tag;
		if(vis[tag]) continue;
		vis[tag] = true;
		ans = max(ans, tmp.dist);
		int len = edges[tag].size();
		for(int i=0; i<len; ++i){
            if(!vis[edges[tag][i].tag])
                q.push(Node(edges[tag][i].tag, edges[tag][i].dist));
		}
	}
	return ans;
}

int main(){
	while(scanf("%d%d", &n, &m)!=EOF){
		init();
		for(int i=0; i<m; ++i){
			scanf("%d%d%d", &a, &b, &c);
			edges[a].push_back(Node(b, c));
			edges[b].push_back(Node(a, c));
		}
		printf("%d\n", prim());
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值