UVA-10878 Decode the tape

UVA-10878 Decode the tape

题目大意:将题目中加密后的字符解密

Sample Input

自己点击链接查看

Sample Output

A quick brown fox jumps over the lazy dog.

解题思路:将题目中的信息转化为二进制信息,依次输出即可

方法一

//UVa 10878 - Decode the tape

#include <iostream>
#include <cstdlib>
#include <cstdio>
using namespace std;

int value[11] = {0,0,64,32,16,8,0,4,2,1,0};

int main()
{
    char buf[12];
    gets(buf);
    while ( gets(buf) && buf[0] != '_' ) {
        int sum = 0;
        for ( int i = 2 ; i < 10 ; ++ i )
            if ( buf[i] == 'o' )
                sum += value[i];
        printf("%c",sum);               //此处不用回车
    }
    return 0;
}

方法二

#include <cstdio>

int main () {
     char c;
     int temp = 0;
     int num = 0;
     while ((c = getchar())!=EOF) {
        if (c == '\n') {
            if (num == 8) {
                 putchar (temp);
                 num = 0;
            }
            temp = 0;
        }
        else {
            if (c == 'o') {
                temp = temp * 2 + 1;
                num++;
            }
            if (c == ' ') {
                temp *=2;
                num++;
            }
        }
     }
     return 0;
}

输出不用回车

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值