1202: GCD

Description

Input

 The first line is an positive integer  T . (1<=T<= 10^3) indicates the number of test cases. In the next T lines, there are three positive integer n, m, p (1<= n,m,p<=10^9) at each line.

Output

Sample Input

1 
1 2 3

Sample Output

1

不难推出的是1+sn=fib(n+2);

所以求的是gcd(fib(n+2),fib(m+2));

然后又有gcd(fib(n),fib(m))=fib(gcd(n,m));

所以最后求的就是fib(gcd(n+2,m+2));

然后fib的第n项用矩阵快速幂求一下就可以了。

#include <bits/stdc++.h>
 
using namespace std;
const int MAXN=1e5+7;
const int inf=1e9;
int n,m,k,mod;
struct matrix
{
    long long a[2][2];
    matrix operator * (const matrix &y)const
    {
        matrix ans;
        ans.a[0][0]=((a[0][0]*y.a[0][0])%mod+(a[0][1]*y.a[1][0])%mod)%mod;
        ans.a[0][1]=((a[0][0]*y.a[0][1])%mod+(a[0][1]*y.a[1][1])%mod)%mod;
        ans.a[1][0]=((a[1][0]*y.a[0][0])%mod+(a[1][1]*y.a[1][0])%mod)%mod;
        ans.a[1][1]=((a[1][0]*y.a[0][1])%mod+(a[1][1]*y.a[1][1])%mod)%mod;
        return ans;
    }
};
long long get_f(int n)
{
    if(n==1||n==2)return 1;
    n-=2;
    matrix result={{1,0,0,1}};
    matrix base={{0,1,1,1}};
    while(n)
    {
        if(n&1)result=result*base;
        base=base*base;
        n>>=1;
    }
    return (result.a[0][1]+result.a[1][1])%mod;
}
 
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&mod);
        printf("%lld\n",get_f(__gcd(n+2,m+2)));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值