SDAU 课程练习2 1011

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. <br>
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.<br>
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.<br>
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0

Sample Output
  
  
0
1
2
2
 

Source
Mid-Central USA 1997

题目大意:

@ 一块为油田,若他的 其他 8 个方向存在另一块 油田 (即 @ 的其他 8个方向有另外的 一个 @),那么就把他们看成是 一大块 油田,问,所给样例中有几块油田。

思路:

DFS 应用。这个题不是树的结构,老师说了,DFS问题用递归解决,用递归的话,首先就是递归出口,当 这块油田被搜索过了,或者搜索越界了,或者搜索不满足条件了。
都应该停止。这些都是递归出口。
然后剩下一个问题就是如何搜索其他 8 个方向
二重 for 循环   均从  -1  ~   1
略过自身    i  = 0  j = 0 ;
问题到这应该就解决了。

感想:

这个题感觉没怎么用到 DFS 和 BFS (虽然我还不太懂) 因为不满足 他的两种树状结构啊 对不对。
起个名字 就叫模拟 搜索吧。嘿嘿   ♪(^∇^*)
 
AC代码:

#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#include<iomanip>
using namespace std;
int m,n;
char oil[200][200];
bool boo[200][200];
void dfs(int x,int y)
{
    if(x<0||x>=m||y<0||y>=n) return ;
    if(boo[x][y]==true||oil[x][y]!='@') return ;
    boo[x][y]=true;
    int i,j;
    for(i=-1;i<2;i++)
        for(j=-1;j<2;j++)
        {
            if(i==0&&j==0)
                continue;
            else
                dfs(x+i,y+j);
        }
}


int main()
{
    //freopen("r.txt","r",stdin);
    int i,j,num;
    while(cin>>m)
    {
        cin>>n;
        if(m==0&&n==0) break;
        num=0;
        memset(boo,false,sizeof(boo));
        for(i=0;i<m;i++)
            scanf("%s",oil[i]);
        //for(i=0;i<m;i++)
          //  puts(oil[i]);
        for(i=0;i<m;i++)
            for(j=0;j<n;j++)
                if(oil[i][j]=='@')
                {
                    if(boo[i][j]==false)
                    {
                        num++;
                        dfs(i,j);
                    }
                }
        cout<<num<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值