SDAU课程练习2 1014

A strange lift

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 91   Accepted Submission(s) : 10
Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 &lt;= Ki &lt;= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button &quot;UP&quot; , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button &quot;DOWN&quot; , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button &quot;UP&quot;, and you'll go up to the 4 th floor,and if you press the button &quot;DOWN&quot;, the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.<br>Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button &quot;UP&quot; or &quot;DOWN&quot;?<br>
 

Input
The input consists of several test cases.,Each test case contains two lines.<br>The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.<br>A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
  
  
5 1 5<br>3 3 1 2 5<br>0
 

Sample Output
  
  
3
 


题目大意:


给出楼层总数,给出起始位置和终点位置。  然后现在 你在一个升降机里面,只能按 上升或者下降,给出  处在每层的时候  升降机运动的层数。也就是说,看样例:

现在处在  1  楼 ,要去  5楼。在  1 楼不可以按 下降,因为不可以降落到 -2 层。如果上升的话,会上升到  4  。也就是说上升或者下降越界的话,就不可以执行。

问 从起点到终点需要的最短次数。如果怎样都到不了没输出 -1


思路:


从 起点 bfs 就好了,还比较简单,只是上下两个状态。


感想:


提醒一下刚开始学习  bfs  的同学们,注意  bfs 的套路!!

这几个题几乎都是一样的!!看到了么??


这份代码进行了剪枝,速度明显提高了好多。嘻嘻  


AC代码:

#include<iostream>
#include<string.h>
#include<queue>
#include<stdio.h>
using namespace std;


int mapp[205];
int vis[205];
int n,st,endd;
struct lift
{
    int x;
    int num;
    friend bool operator < (lift a,lift b)
    {
        return a.num>b.num;
    }
};




int bfs()
{
    priority_queue<lift>que;
    lift star;
    star.x=st;
    star.num=0;
    que.push(star);
    lift now,now1;
    while(!que.empty())
    {
        now=que.top();
        que.pop();
        vis[now.x]=1;
       if(now.x==endd)
       {
           int t=now.num;
            return t;
       }
       now1=now;




            now.x=now.x+mapp[now.x];
            now.num++;
            if(now.x>0&&now.x<=n&&!vis[now.x])
                que.push(now);


            now1.num++;
            now1.x=now1.x-mapp[now1.x];
            if(now1.x>0&&now1.x<=n&&!vis[now1.x])
                que.push(now1);




    }
    return 0;
}


int main()
{
    int i,j;
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        cin>>st>>endd;
        for(i=1;i<=n;i++)
           scanf("%d",&mapp[i]);
       memset(vis,0,sizeof(vis));
        int work=0;
        if(st==endd)
        {
            cout<<0<<endl;
            continue;
        }
        work=bfs();
        if(work)
            cout<<work<<endl;
        else
            cout<<-1<<endl;
    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值