poj 1952buy low, buy lower

The advice to "buy low" is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems' advice: 
                    "Buy low; buy lower"

Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices. 

You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy. 

Here is a list of stock prices: 
 Day   1  2  3  4  5  6  7  8  9 10 11 12 
Price 68 69 54 64 68 64 70 67 78 62 98 87


The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is: 
Day    2  5  6 10 
Price 69 68 64 62

Input

* Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given 

* Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers. 

Output

Two integers on a single line: 
* The length of the longest sequence of decreasing prices 
* The number of sequences that have this length (guaranteed to fit in 31 bits) 

In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they "look the same" when the successive prices are compared. Thus, two different sequence of "buy" days could produce the same string of decreasing prices and be counted as only a single solution. 

Sample Input

12
68 69 54 64 68 64 70 67 78 62
98 87

Sample Output

4 2


coun[ i ]是表示以第 i 天为结尾的最长递减子序列的长度种类数,

它与dp数组同步维护,分三种情况

1.dp【i】到了一个新的长度dp【j】,使coun【i】被更改为coun【j】;

2.dp【j】+1==dp【i】,表示从 j 可以一步到 i ,然后便加上这种情况。

3.两者数字相同,而且此时dp【i】==1时,用第i个位置上的数字替换第j个位置上的数字,形成的序列完全相同,coun【j】=0。

之所以加上条件dp【i】==1,是因为,若是dp【i】!=1,说明第 i 处形成了其他的递减子串,不能清为0.

#include<iostream>
#include<cstring>
#include<stdio.h>

using namespace std;

int price[5010],N;
int dp[5010];
int coun[5010];
const int inf=0x3f3f3f3f;

int max(int a,int b)
{
    return a>b?a:b;
}
void DP()
{
    for(int i=1;i<=N;++i )
    {
        for(int j=i-1;j>=1;--j)
        {
            if(price[i]<price[j])
            {
               if(dp[i]<dp[j]+1)
               {
                   dp[i]=dp[j]+1,coun[i]=coun[j];
               }
               else if(dp[i]==dp[j]+1)
               {
                   coun[i]+=coun[j];
               }
            }
            else
            {
                if(price[i]==price[j])
                {
                    if(dp[i]==1)
                    coun[i]=0;
                    break;
                }
            }
        }
    }
    int maxx=-inf,num=0;
    for(int i=1;i<=N;++i)
    {
      //cout<<dp[i]<<' ';
      maxx=max(maxx,dp[i]);
    }
    for(int i=1;i<=N;++i)
    {
        if(dp[i]==maxx)
            num+=coun[i];
    }
    cout<<maxx<<' '<<num<<endl;
}
int main()
{
  // freopen("in.txt","r",stdin);
   while(cin>>N)
   {
        for(int i=1;i<=N;++i)
        dp[i]=1,coun[i]=1;
        for(int i=1;i<=N;++i)
            cin>>price[i];
        DP();
   }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值