POJ 2632 Crashing Robots 模拟

D - Crashing Robots

Time Limit:1000MS     Memory Limit:65536KB    64bit IO Format:%lld & %llu

 

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 

 
Figure 1: The starting positions of the robots in the sample warehouse


Finally there are M lines, giving the instructions in sequential order. 
An instruction has the following format: 
< robot #> < action> < repeat> 
Where is one of 

· L: turn left 90 degrees, 

· R: turn right 90 degrees, or 

· F: move forward one meter,


and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case: 

· Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.) 

· Robot i crashes into robot j, if robots i and j crash, and i is the moving robot. 

· OK, if no crashing occurs.


Only the first crash is to be reported.

Sample Input

4

5 4

2 2

1 1 E

5 4 W

1 F 7

2 F 7

5 4

2 4

1 1 E

5 4 W

1 F 3

2 F 1

1 L 1

1 F 3

5 4

2 2

1 1 E

5 4 W

1 L 96

1 F 2

5 4

2 3

1 1 E

5 4 W

1 F 4

1 L 1

1 F 20

Sample Output

Robot 1 crashes into the wall

Robot 1 crashes into robot 2

OK

Robot 1 crashes into robot 2

 

本题乍一看上去有图有路径的,好像是搜索,但当实际做完后又不是完全的搜索,因为它的路径移动有三种类型:

一是沿着该机器人的朝向forward向前走;

二是向左转;

三是向右转;

然而需要注意的是二三向左向右转都不动,只是朝向发生变化.

我选择用结构体设置三个成员量分别是两个位置参数,还有一个字符量存取朝向的参数。设置最大的机器人数量数组;

最后有一个大坑就是题目中给的坐标和我们的定势思维中的坐标是不同的,题目中是右下角为(1,1)点,而我们习惯于把二维数组的[1][1]左上角当成(1,1)点。


仍然得不到返回值。

AC代码如下:

 

 

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct node
{
    char dir;
    int rx;
    int ry;
}r[101];
int pic[110][110]; //地图数组
int x,y;
int p;
int dfs(int tx,int ty,char d,int No,int step)
{
    if(tx<1||ty<1||tx>x||ty>y) //判断是否撞墙
    {
        printf("Robot %d crashes into the wall\n",No);
        return 0;
    }
    else if(pic[tx][ty]!=0) //判断是否撞上机器人,pic数组中有值说明这个点上有机器人,没值说明这个点是空的没有机器人,用标号设置机器人的值,然后
    { //如果撞上了直接就输出该点的标号值就是撞到的机器人号。
        printf("Robot %d crashes into robot %d\n",No,pic[tx][ty]);
        return 0;
    }
    else if(step==0) //递归调用后如果最后步数为零又经过了上面两个if的考验说明可以成功返回
    {     
  pic[tx][ty]=No;
        r[No].rx=tx;
        r[No].ry=ty;
        return 1;
    }


    if(d=='L')
    {
        while(step--)
        {
            if(r[No].dir=='W')
            r[No].dir='S';
            else if(r[No].dir=='E')
            r[No].dir='N';
            else if(r[No].dir=='S')
            r[No].dir='E';
            else if(r[No].dir=='N')
            r[No].dir='W';
        }


        return 1;
    }
    else if(d=='R')
    {
        while(step--)
        {
            if(r[No].dir=='W')
            r[No].dir='N';
            else if(r[No].dir=='E')
            r[No].dir='S';
            else if(r[No].dir=='S')
            r[No].dir='W';
            else if(r[No].dir=='N')
            r[No].dir='E';
        }
        return 1;
    }
    else if(d=='F')
    {
        if(r[No].dir=='W')
        {
            if(dfs(tx-1,ty,d,No,step-1))
            return 1;
            else
            return 0;
        }
        else if(r[No].dir=='E')
        {
            if(dfs(tx+1,ty,d,No,step-1))
            return 1;
            else return 0;
        }
        else if(r[No].dir=='N')
        {
            if(dfs(tx,ty+1,d,No,step-1))
            return 1;
            else
            return 0;
        }
        else if(r[No].dir=='S')
        {
            if(dfs(tx,ty-1,d,No,step-1))
            return 1;
            else
            return 0;
        }
    }
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(pic,0,sizeof(pic));
        scanf("%d%d",&x,&y);
        int rob,ins;
        scanf("%d%d",&rob,&ins);
        for(int i=1;i<=rob;i++)
        {
            int sx,sy;
            char ch;


            scanf("%d%d",&sx,&sy);
            getchar();
            ch=getchar();
            pic[sx][sy]=i;
            r[i].dir=ch;
            r[i].rx=sx;
            r[i].ry=sy;
        }
        int c=ins;
        p=0;
        int flag=1;
        for(int i=0;i<c;i++)
        {
            int No,step;
            char d;
            scanf("%d",&No);   //注意这里没有跳过空格吸收字符
            getchar();
            scanf("%c",&d);
            scanf("%d",&step);
            pic[r[No].rx][r[No].ry]=0;
            if(p==0)
            if(dfs(r[No].rx,r[No].ry,d,No,step)==0)
            p++;
        }
        if(p==0)
        printf("OK\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值