poj 2184 Cow Exhibition (0-1 + 负数变正数)

题目链接:http://poj.org/problem?id=2184


Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12680 Accepted: 5065

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

Source

[Submit]   [Go Back]   [Status]   [Discuss]



题目大意:每个牛都有自己的 smart and fun ,给出 n 头,从中选择和最大的smart and fun(两个必须 > 0),没有输出 0

解析:        0-1背包,题中有负数,所以会数组越界,每个数都加上10000,先变成正数再计算,然后就是0-1背包选择了,容量为200000


代码如下:

#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 300009
using namespace std;
const int inf = 0x3f3f3f3f;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;

int dp[N], a[110], b[110];

int main()
{
    int i, j, n;
    scanf("%d", &n);
    for(i = 1; i <= n; i++)  scanf("%d%d", &a[i], &b[i]);
    for(i = 0; i <= 200000; i++) dp[i] = -inf;
    dp[100000] = 0;

    for(i = 1; i <= n; i++)
    {
        if(a[i] < 0 && b[i] < 0) continue;
        if(a[i] > 0)
        {
            for(j = 200000; j >= a[i]; j--) if(dp[j - a[i]] > -inf) dp[j] = max(dp[j], dp[j - a[i]] + b[i]);
        }
        else
        {
            for(j = 0; j <= 200000 + a[i]; j++) if(dp[j - a[i]] > -inf) dp[j] = max(dp[j], dp[j - a[i]] + b[i]); // 保证j - a[i] 之前没有选择a[i],不然状态重复
        }
    }

    int ans = 0;
    for(i = 100000; i <= 200000; i++)
    {
        if(dp[i] > 0)
        ans = max(ans, dp[i] + i - 100000);

    }
    printf("%d\n", ans);
    return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值