POJ 3104 Drying(二分逼近)

题目链接:http://poj.org/problem?id=3104


Drying
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13975 Accepted: 3598

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

Source

Northeastern Europe 2005, Northern Subregion

[Submit]   [Go Back]   [Status]   [Discuss]



题目大意:输入n,然后n件衣服的含水量a[i],给你一个吹风机,每秒衣服自动凉会减1个水量,用吹风机共减k水量,求最短时间

题目解析:二分时间,最后找出最优解,比较坑的是,数据爆了int,要用long long

代码如下:


#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 100009
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;
int a[N];

int main()
{
    int n, k, i, j;
    LL l, r;
    while(~scanf("%d", &n))
    {
        l = r = 0;
        for(i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            r += a[i];
        }
        scanf("%d", &k);
        sort(a + 1, a + 1 + n);
        if(k == 1) printf("%d\n", a[n]);
        else
        {
            LL ans = 0;
            while(l <= r)
            {
                LL md = (l + r) >> 1;
                LL m = 0;
                for(j = 1; j <= n; j++)
                {
                    if(a[j] - md <= 0) continue;
                    m = m + ceil((a[j] - md) * 1.0 / (k - 1));
                }
                if(m <= md) ans = md, r = md - 1;
                else l = md + 1;
            }
            printf("%lld\n", ans);
        }
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值