HDOJ 4632 Palindrome subsequence

Palindrome subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65535 K (Java/Others)
Total Submission(s): 3090    Accepted Submission(s): 1276


Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <S x1, S x2, ..., S xk> and Y = <S y1, S y2, ..., S yk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if S xi = S yi. Also two subsequences with different length should be considered different.
 

Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
 

Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
 

Sample Input
  
  
4 a aaaaa goodafternooneveryone welcometoooxxourproblems
 

Sample Output
  
  
Case 1: 1 Case 2: 31 Case 3: 421 Case 4: 960
 

题意就是求字符串的不同回文串的个数;
比较简单的区间dp,先把这个字符串细分,设dp[i][j]表示的是区间i-j内的个数,当区间长度为1时,个数也为1,然后从2-n不断的枚举区间长度,枚举区间的起点,对于每一个区间,dp[i][j]=dp[i][j-1]+dp[i+1][j]-dp[i+1][j-1],减去的就是两个区间合并过程中重复加的回文串,如果s[i]==s[j],说明当两个区间合并的时候以i,j开始和结尾存在新的回文串,那么就要加上dp[i+1][j-1]+1,这个1表示的是i,j回文串。




#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<string.h>
using namespace std;
int dp[1005][1005];
char s[1005];
int mod=10007;
int main()
{
    int t,c=0;
    scanf("%d",&t);
    while(t--)
    {
        c++;
        memset(dp,0,sizeof(dp));
        scanf("%s",s);
        int n=strlen(s);
        for(int i=0;i<n;i++)
            dp[i][i]=1;
        for(int len=2;len<=n;len++)
        {
            for(int i=0;i+len<=n;i++)
            {
                int l=i;
                int r=i+len-1;
                dp[l][r]=dp[l][r-1]+dp[l+1][r];
               
                if(s[l]==s[r])
                    dp[l][r]++;
                else
                    dp[l][r]-=dp[l+1][r-1];

                dp[l][r]%=mod;
                if(dp[l][r]<0)
                    dp[l][r]+=mod;
            }
        }
        printf("Case %d: %d\n",c,dp[0][n-1]);
    }
return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值