bzoj1648: [Usaco2006 Dec]Cow Picnic 奶牛野餐 (搜索+剪枝)

1648: [Usaco2006 Dec]Cow Picnic 奶牛野餐

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 692   Solved: 422
[ Submit][ Status][ Discuss]

Description

The cows are having a picnic! Each of Farmer John's K (1 <= K <= 100) cows is grazing in one of N (1 <= N <= 1,000) pastures, conveniently numbered 1...N. The pastures are connected by M (1 <= M <= 10,000) one-way paths (no path connects a pasture to itself). The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.

  K(1≤K≤100)只奶牛分散在N(1≤N≤1000)个牧场.现在她们要集中起来进餐.牧场之间有M(1≤M≤10000)条有向路连接,而且不存在起点和终点相同的有向路.她们进餐的地点必须是所有奶牛都可到达的地方.那么,有多少这样的牧场呢?

Input

* Line 1: Three space-separated integers, respectively: K, N, and M * Lines 2..K+1: Line i+1 contains a single integer (1..N) which is the number of the pasture in which cow i is grazing. * Lines K+2..M+K+1: Each line contains two space-separated integers, respectively A and B (both 1..N and A != B), representing a one-way path from pasture A to pasture B.

 1行输入KNM.接下来K行,每行一个整数表示一只奶牛所在的牧场编号.接下来M行,每行两个整数,表示一条有向路的起点和终点

Output

* Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.

    所有奶牛都可到达的牧场个数

Sample Input

2 4 4
2
3
1 2
1 4
2 3
3 4


INPUT DETAILS:

4<--3
^ ^
| |
| |
1-->2

The pastures are laid out as shown above, with cows in pastures 2 and 3.

Sample Output

2

牧场3,4是这样的牧场.

HINT

Source

Silver


随便搜一搜就好。。。。。。。

感觉自己noip前刷这么多水题真的只是在找自信而已QAQ。。。。。。

复杂度O(n*k)


附代码:



#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<climits>
#include<map>
#include<set>
#include<queue>
#include<cstring>
#define N 1010
#define M 200002
using namespace std;
int k,n,m,T;
int id[N],head[N],pos,cnt[N];
struct edge{int to,next;}e[M];
void add(int a,int b){pos++;e[pos].to=b,e[pos].next=head[a];head[a]=pos;}
int used[N],ans;
void dfs(int u)
{
	cnt[u]++;used[u]=T;
	for(int i=head[u];i;i=e[i].next)
		{
			int v=e[i].to;
			if(used[v]==T)continue;
			dfs(v);
		}
}
int main()
{
	scanf("%d%d%d",&k,&n,&m);
	for(int i=1;i<=k;i++)
		scanf("%d",&id[i]);
	for(int i=1,a,b;i<=m;i++)
		{
			scanf("%d%d",&a,&b);
			add(a,b);
		}
	for(int i=1;i<=k;i++)
		{
			T=i;
			dfs(id[i]);
		}
	for(int i=1;i<=n;i++)if(cnt[i]==k)ans++;
	printf("%d\n",ans);
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值