HDU 5417 Victor and Machine by Assassin 简单模拟

Problem Description
Victor has a machine. When the machine starts up, it will pop out a ball immediately. After that, the machine will pop out a ball every
w
seconds. However, the machine has some flaws, every time after
x
seconds of process the machine has to turn off for
y
seconds for maintenance work. At the second the machine will be shut down, it may pop out a ball. And while it’s off, the machine will pop out no ball before the machine restart.

Now, at the
0
second, the machine opens for the first time. Victor wants to know when the
n
-th ball will be popped out. Could you tell him?

Input
The input contains several test cases, at most
100
cases.

Each line has four integers
x
,
y
,
w
and
n
. Their meanings are shown above。

1≤x,y,w,n≤100
.

Output
For each test case, you should output a line contains a number indicates the time when the
n
-th ball will be popped out.

Sample Input
2 3 3 3
98 76 54 32
10 9 8 100

Sample Output
10
2664
939

思路:就是纯模拟,想清楚就行了。总共就那么几个变化量,一个是机器是否开的我用的butter,一个是如果机器开的弹出球加1需要满足剩下的工作时间大于w,用一个rest记录就行了,其他的都是可有可无的,分享我的丑代码

#include<bits/stdc++.h>
#define input freopen("input.txt","r",stdin)
using namespace std;
int main(){
    int x,y,w,n,butter,num,readyon,rest,times;
    while(scanf("%d%d%d%d",&x,&y,&w,&n)!=EOF){
        num=0;
        butter=times=0;
        readyon=y;
        while(num<n){
            if(butter==0&&readyon==y){
                num++;
                butter=1;
                rest=x;
            }
            else if(butter==0&&readyon==0){
                readyon=y;
                times+=y;
            }
            else if(butter==1&&rest>=w){
                num++;
                rest-=w;
                times+=w;
            }
            else if(butter==1&&rest<w){
                times+=rest;
                butter=0;
                readyon=0;
            }
        }
        cout<<times<<endl;
    }
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值