hdu1005 Number Sequence (思维+规律)

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 158192    Accepted Submission(s): 38749


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

题解:因为给的n比较大,直接递归的话很超时,题中给出公式如果直接代入对的话,说明出题人脑子有问题,所以给出了运算公式的数学凡是没有优化的话,超时超内存等等是避免不了的了.
因为对7取余,f(n)<7,所以会出现循坏,也就是f(n)=1&&f(n-1)=1,这是就能知道了,最多也就7*7=49种情况。
#include<cstdio>
int f[10005];
int main()
{
	long long a,b,n,i;
	while(scanf("%lld%lld%lld",&a,&b,&n)&&(a||b||n))
	{
		f[1]=f[2]=1;
		for(i=3;i<=1000;i++)
		{
			f[i]=(a*f[i-1]+b*f[i-2])%7;
			if(f[i]==1&&f[i-1]==1)
			  break;
		}
	    n=n%(i-2);
	    f[0]=f[i-2];
	    printf("%d\n",f[n]);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值