HDU 1885 Key Task 状态压缩+BFS

26 篇文章 0 订阅

Key Task

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Problem Description
The Czech Technical University is rather old — you already know that it celebrates 300 years of its existence in 2007. Some of the university buildings are old as well. And the navigation in old buildings can sometimes be a little bit tricky, because of strange long corridors that fork and join at absolutely unexpected places.
The result is that some first-graders have often di?culties finding the right way to their classes. Therefore, the Student Union has developed a computer game to help the students to practice their orientation skills. The goal of the game is to find the way out of a labyrinth. Your task is to write a verification software that solves this game.
The labyrinth is a 2-dimensional grid of squares, each square is either free or filled with a wall. Some of the free squares may contain doors or keys. There are four di?erent types of keys and doors: blue, yellow, red, and green. Each key can open only doors of the same color.
You can move between adjacent free squares vertically or horizontally, diagonal movement is not allowed. You may not go across walls and you cannot leave the labyrinth area. If a square contains a door, you may go there only if you have stepped on a square with an appropriate key before.
Input
The input consists of several maps. Each map begins with a line containing two integer numbers R and C (1 ≤ R, C ≤ 100) specifying the map size. Then there are R lines each containing C characters. Each character is one of the following:
这里写图片描述
Note that it is allowed to have
more than one exit,
no exit at all,
more doors and/or keys of the same color, and
keys without corresponding doors and vice versa.
You may assume that the marker of your position (“*”) will appear exactly once in every map.
There is one blank line after each map. The input is terminated by two zeros in place of the map size.
Output
For each map, print one line containing the sentence “Escape possible in S steps.”, where S is the smallest possible number of step to reach any of the exits. If no exit can be reached, output the string “The poor student is trapped!” instead.
One step is defined as a movement between two adjacent cells. Grabbing a key or unlocking a door does not count as a step.
Sample Input
1 10
*……..X
1 3
*#X
3 20

#

XY.gBr.*.Rb.G.GG.y

#

0 0
Sample Output
Escape possible in 9 steps.
The poor student is trapped!
Escape possible in 45 steps.

#include <iostream>  
#include <queue>  
#include <cstring>  
#include <cstdio>  
#include <map>  
using namespace std;  

const int maxn = 102;  

int dir[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};  
char vis[maxn][maxn];  
int step[(1<<5)][maxn][maxn];  
int N, M;  
int key;  
struct Node  
{  
    int state;  
    int x, y;  
};  
queue<Node> q;  
map<char, int> Map, m;  

void init()  
{  
    key = 0;  
    memset(step, -1, sizeof(step));  
    while (!q.empty()) q.pop();  
}  

bool Wall(int x, int y)  
{  
    if (x<0 || y<0 || x>=N || y>=M) return true;  
    if (vis[x][y] == '#') return true;  
    return false;  
}  

//判断在state状态下,能否打开目前的门  
bool door(int x, int y, int state)  
{  
    if (vis[x][y] >= 'A' && vis[x][y] <= 'Z' && vis[x][y] != 'X')  
    {  
        int s = Map[vis[x][y]];  
        if (((1<<s) & state) != 0)  
            return false;  
        else  
            return true;  
    }  
    return false;  
}
int bfs(){  
    while (!q.empty()) {  
        Node n = q.front();  
        q.pop();  
        if (vis[n.x][n.y] == 'X')  
            return step[n.state][n.x][n.y];  

        int newstate = n.state;  
        for (int i=0; i<4; i++)  
        {  
            int nx = n.x + dir[i][0];  
            int ny = n.y + dir[i][1];  
            if (Wall(nx, ny) || door(nx, ny, n.state)) continue;  
            if (step[newstate][nx][ny] != -1) continue;  
            if (vis[nx][ny] >= 'a' && vis[nx][ny] <= 'z')  
                newstate = ((1<<m[vis[nx][ny]]) | n.state);  
            else  
                newstate = n.state;  
            Node tmp;  
            tmp.state = newstate, tmp.x = nx, tmp.y = ny;  
            step[newstate][nx][ny] = step[n.state][n.x][n.y] + 1;  
            q.push(tmp);  
        }  
    }  
    return -1;  
}  

int main(){
    Map['B'] = 1;Map['Y'] = 2;Map['R'] = 3;Map['G'] = 4;
    m['b'] = 1;m['y'] = 2;m['r'] = 3;m['g'] = 4;  
    while(scanf("%d %d",&N,&M),N&&M){
        getchar();
        init();
        int i, j;
        Node s;
        s.state=0;
        for (i=0; i<N; i++){
            for (j=0; j<M; j++){  
                char c = getchar();
                if(c == '*') s.x = i, s.y = j;  
                vis[i][j] = c;
            }  
            getchar();
        }  
        step[0][s.x][s.y] = 0;
        q.push(s);
        int ans = bfs();
        if(ans == -1) puts("The poor student is trapped!");  
        else printf("Escape possible in %d steps.\n", ans);  
    }
    return 0;  
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值