关闭

Unsupported major.minor version 51.0解决方法

标签: strutsjavawebmyeclipse
485人阅读 评论(0) 收藏 举报
分类:

在刚运行struts项目的过滤器的时候,可能会遇到下边这个问题,弄了好久, 终于解决了,分享一下:

由于一开始是自己写代码进去,即过滤器是通过手写的,并且在web.xml中是自己配置过滤器的,而不是myeclipse自动生成,所以一直报错,后来发现myeclipse在添加了struts项目之后,会自动配置生成的。解决了路径那个问题。(总结Myeclipse中,打开WEB-INF--web.xml--design--选择filter,然后填写相关的路径等信息,这样比手写快捷方便,更能避免了路径问题。


(1)在弄好了以后,运行时候控制台又出现了报错,就是以下的错误:

Unsupported major.minor version 51.0(jdk版本错误)

Java.lang.UnsupportedClassVersionError: org/apache/nutch/crawl/Crawl3 : Unsupported major.minor version 51.0

 

查了很久的资料,终于找到了解决的方法:

原因:如果在win7下开发项目是使用的jdk版本和项目运行服务器jdk版本不同就会出现上面的问题。

解决方法:修改项目java compiler的方法:在项目点右键->选择Perperties->在出现的菜单中选择Java Compiler->最上面选中Enable project Specific setting->然后将jdk改为jdk1.6->完成。然后执行,成功地打开页面。

 


1
0
查看评论

MAVEN的下载和安装-Unsupported major.minor version 51.0

1、下载 http://maven.apache.org/download.cgi 2、注意jdk版本提示 3、将下载的文件解压到某个目录 比如D:\apache-maven-3.3.9 4、配置环境变量 先要配置好jdk 然后是MAVEN的配置:M2_HOME 在...
  • bestcxx
  • bestcxx
  • 2016-08-05 11:01
  • 4595

Unsupported major.minor version 51.0 错误处理

今天在发布系统新版本后,启动服务器(包括tomcat跟weblogic)就莫名其妙的报了Unsupported major.minor version 51.0这个错,其中启动tomcat时总是一闪而过,编辑startup.bat,在文本的最后加上pause后也看不到错误信息,在日志文件中或者web...
  • sp1203
  • sp1203
  • 2015-07-09 16:12
  • 982

jfinal启动报错Unsupported major.minor version 51.0原因深入分析

导入了一个工程,使用了jfinal框架,部署到tomcat,启动之后,发现报如下错误 java.lang.UnsupportedClassVersionError: com/jfinal/core/JFinalFilter : Unsupported major.minor version 51.0...
  • u013287668
  • u013287668
  • 2016-08-14 14:34
  • 1776

MAC OSX配置maven以及遇到问题:Unsupported major.minor version 51.0

由于准备自己学习maven,从网上找方法安装配置,结果却出现了 Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : Unsuppor...
  • maxu12345
  • maxu12345
  • 2015-12-09 16:42
  • 1040

springboot + jdk6:Unsupported major.minor version 51.0

官方文档: How to use Java 6 If you want to use Spring Boot with Java 6 there are a small number of configuration changes that you will have to mak...
  • u011461420
  • u011461420
  • 2016-07-05 16:03
  • 2887

Unsupported major.minor version 51.0(jdk版本错误)

最近在进行hadoop的开发时遇到了一个问题,现将此记录下来! 前一阵子搭建了hadoop的开发环境(win8+eclipse4.3+hadoop1.1.2+centerOS6.4),最近在eclipse下创建了一个实例,将其打包为jar文件后 发布到linux环境下执行时报了一个错: ...
  • zwx19921215
  • zwx19921215
  • 2014-02-25 10:37
  • 5524

安装maven3.3.3出现Unsupported major.minor version 51.0问题

首先查看jdk的安装版本信息如下: java version "1.6.0_45" 将maven解压好之后再环境变量中配置maven路径 M2_HOME:E:\professionalsoft\apache-maven-3.3.3 在path中添加maven:%M2_HO...
  • u010597526
  • u010597526
  • 2015-07-02 11:17
  • 1839

hadoop集成到myeclipse中报错/MapReducePreferencePage : Unsupported major.minor version 51.0解决方案

使用的插件为hadoop-eclipse-plugin-2.6.4.jar,放在了D:\Program Files\MyEclipse\MyEclipse 10\dropins这个目录下,结果重启myeclipse后出现org/apache/hadoop/eclipse/preferences/Ma...
  • menghuannvxia
  • menghuannvxia
  • 2017-04-13 16:13
  • 752

项目迁移报错Unsupported major.minor version 51.0的问题及解决方法

项目从另外一台电脑上换到另外一台电脑上,tomcat部署启动时报错 *Unsupported major.minor version 51.0 百度谷歌搜索解决方案如下解决unsupported major.minor version 51.0错误*最近新安装使用了jdk7,编译了一些类替换到原...
  • sinat_25926481
  • sinat_25926481
  • 2016-07-06 11:21
  • 1160

MAVEN打包到服务器出现:Unsupported major.minor version 51.0

本地环境是JDK1.7,服务器是JDK1.6,将本地的多模块项目打包放到服务器的Tomcat中报 Unsupported major.minor version 51.0 错误,网上搜索得知这个现象是因为使用了高版本的Compile Level 导致,但是我由于粗心一直没有解决这个问题,因为...
  • babys
  • babys
  • 2014-11-30 22:52
  • 3567
    个人资料
    • 访问:104090次
    • 积分:2640
    • 等级:
    • 排名:第16297名
    • 原创:134篇
    • 转载:102篇
    • 译文:0篇
    • 评论:8条
    最新评论