Can you answer these queries?(点更新,区间查询)

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
Output For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8
Sample Output
Case #1:
19
7
6

这道题,应该是点更新,但是,会超时,所以我们想1,不管怎么平方根,都是1,所以我们就标记这个1,把它标记下来。下次一看是1,我们就不用往下走了。

还有竟然是,左不一定大于右

(点更新,区间查询)-->(不用每次点更新,可以忽略一些)-->(区间更新,区间查询)

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long ll;
const int maxn=1e5+10;
 
struct node{
	int l,r;
	ll sum;
	int flag;
}tree[maxn*4];

void pushup(int o){
	tree[o].flag=(tree[o<<1].flag)&&(tree[o<<1|1].flag);
	tree[o].sum=tree[o<<1].sum+tree[o<<1|1].sum;
}

void build(int l,int r,int o){
	tree[o].l=l,tree[o].r=r;
	tree[o].flag=0;
	if(l==r){
		scanf("%I64d",&tree[o].sum);
		if(tree[o].sum==1) tree[o].flag=1;
		return;
	}
	int mid=(l+r)>>1;
	build(l,mid,o<<1);
	build(mid+1,r,o<<1|1);
	pushup(o); 
}

void update(int l,int r,int o){
	if(tree[o].flag) return;//此树所管辖的区间已经不可能在 sqrt了 
	if(tree[o].l==tree[o].r){
		tree[o].sum=(ll)sqrt(tree[o].sum);
		if(tree[o].sum==1) tree[o].flag=1;
		return;
	}
	int mid=(tree[o].l+tree[o].r)>>1;
	if(r<=mid)
		update(l,r,o<<1);
	else if(l>mid)
		update(l,r,o<<1|1);
	else{
		update(l,mid,o<<1);
		update(mid+1,r,o<<1|1);
	}
	pushup(o);
}

ll query(int l,int r,int o){
	if(tree[o].flag)
		return r-l+1;
	if(tree[o].l>=l&&tree[o].r<=r)
		return tree[o].sum;
	int mid=(tree[o].l+tree[o].r)>>1;
	if(r<=mid)
		return query(l,r,o<<1);
	else if(l>mid)
		return query(l,r,o<<1|1);
	else{
		ll ans1=query(l,mid,o<<1);
		ll ans2=query(mid+1,r,o<<1|1);//写错树节点,导致一直向右走,然而在这个区间的最大值,
		                               //也比l小所以不停的向右走,到了叶子节点也是这样,所以越界 
		return ans1+ans2;
	} 
}

int main(){
	int n;
	int cnt=1;
	while(~scanf("%d",&n)){
		build(1,n,1);
		int m;
		scanf("%d",&m);
		printf("Case #%d:\n",cnt++);
		while(m--){
			int c,a,b;
			scanf("%d %d %d",&c,&a,&b);
			if(a>b) swap(a,b); //谁能想到 
			if(c==0)
				update(a,b,1);
			else
				printf("%I64d\n",query(a,b,1)); 
		}
		printf("\n");
	}
	return 0;
} 





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值