树结构练习——排序二叉树的中序遍历

树结构练习——排序二叉树的中序遍历

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
在树结构中,有一种特殊的二叉树叫做排序二叉树,直观的理解就是——(1).每个节点中包含有一个关键值 (2).任意一个节点的左子树(如果存在的话)的关键值小于该节点的关键值 (3).任意一个节点的右子树(如果存在的话)的关键值大于该节点的关键值。现给定一组数据,请你对这组数据按给定顺序建立一棵排序二叉树,并输出其中序遍历的结果。
 
Input
输入包含多组数据,每组数据格式如下。
第一行包含一个整数n,为关键值的个数,关键值用整数表示。(n<=1000)
第二行包含n个整数,保证每个整数在int范围之内。
Output
为给定的数据建立排序二叉树,并输出其中序遍历结果,每个输出占一行。
 
Example Input
1
2
2
1 20
Example Output
2
1 20
Hint
 
Author
 赵利强

#include <bits/stdc++.h>
using namespace std;

struct Btree
{
    int data;
    struct Btree *lc, *rc;
};

void creat(struct Btree *&root, int key)//建排序树
{
    if(root == NULL)
    {
        root = new Btree;
        root ->data = key;
        root ->lc = NULL;
        root -> rc = NULL;



    }
    else
    {
        if(key < root -> data)
            creat(root -> lc,key);
        else
            creat(root -> rc,key);
    }
}

int ss[10010];
int i;

void LDR(struct Btree*root)//中序遍历
{
    if(root)
    {
        LDR(root -> lc);
        ss[i++] = root->data;
        LDR(root -> rc);
    }
}

int main()
{
    int n;
    int key;
    while(cin>>n)
    {
        struct Btree *root = NULL;
        while(n--)
        {
            cin>>key;
            creat(root,key);
        }
        i = 0;
        LDR(root);
        for(int j = 0; j < i; j++)
        {
            if(j != 0)
                cout<<" ";
            cout<<ss[j];
        }
        cout<<endl;
        memset(ss,0,sizeof(ss));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值