HDU3652[B-number]

Problem Description

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string “13” and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
####Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

Output

Print each answer in a single line.

Sample Input

13
100
200
1000

Sample Output

1
1
2
2

题目大意:求出在1~n的整数中,满足含有字串“13”,以及能被13整除的数的个数

题解:数位DP

DP[pos][mod][chk][now]来表示在第pos位,与十三取膜为MOD,含有或不含字串“13”, 最后一位是now时满足题目条件的整数个数。

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

int a[15], dp[15][15][3][10];

int dfs( int pos, int mod, int chk, int now,int flg ){
    if ( pos == -1 ) return (!mod) && chk;
    if ( !flg && dp[pos][mod][chk][now] != -1 ) return dp[pos][mod][chk][now];
    int up = flg ? a[pos] : 9, ret = 0;
    for ( int i = 0; i <= up; i++) ret += dfs( pos-1, (mod*10+i)%13, chk || ( now == 1 && i == 3), i, flg && ( i == up) );
    if ( !flg ) dp[pos][mod][chk][now] = ret;
    return ret;
} 
int solve( int x ){
    int pos = 0;
    for ( ; x; a[pos++] = x % 10, x /= 10);
    return dfs( pos-1, 0, 0, 0, 1);
}
int main(){
    int m;
    memset( dp, -1, sizeof(dp));
    while ( ~scanf( "%d", &m) ){
        printf( "%d\n", solve( m ));
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值