company

题目描述

There are n kinds of goods in the company, with each of them has a inventory of cnti and direct unit benefit vali. Now you find due to price changes, for any goods sold on day i, if its direct benefit is val, the total benefit would be ival.
Beginning from the first day, you can and must sell only one good per day until you can't or don't want to do so. If you are allowed to leave some goods unsold, what's the max total benefit you can get in the end?

输入

The first line contains an integers n(1≤n≤1000).
The second line contains n integers val1,val2,..,valn(−100≤vali.≤100).
The third line contains n integers cnt1,cnt2,..,cntn(1≤cnti≤100).

输出

Output an integer in a single line, indicating the max total benefit.

Hint: sell goods whose price with order as -1, 5, 6, 6, the total benefit would be -1*1 + 5*2 + 6*3 + 6*4 = 51.

样例输入
4-1 -100 5 61 1 1 2
样例输出
51

前缀和的应用

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>

using namespace std;
#define mod 1000000007
#define INF 0x3f3f3f3f
#define N 1000
int val[N],cnt[N];
int b[N*100];
int sum[N*100];
int main()
{
    int n;
    scanf("%d",&n);
    for(int i = 0; i < n; i++)
        scanf("%d",&val[i]);
    for(int i = 0; i < n; i++)
        scanf("%d",&cnt[i]);
    int k = 0;
    for(int i = 0; i < n; i++) {
        for(int j = 0; j < cnt[i]; j++) {
            b[k++] = val[i];
        }
    }
    k--;
    sort(b,b+k+1);
  //  for(int i = 0;i <= k;i++)
 //       printf("%d ",b[i]);
 //   cout << endl;
    long long ans = 0,t;
    for(int i = 0; i <= k; i++) {
        if(i == 0) {
            sum[i] = b[i];
            ans = b[i];
            continue;
        }
        sum[i] = sum[i-1] + b[i];
        ans += (i + 1) * b[i];
    }
    for(int i = 0; i <= k; i++) {
        t = ans  - (sum[k] - sum[i] + b[i]);
        if(t > ans)
            ans = t;
    }
    printf("%lld\n",ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值