POJ Feel Good (单调栈)

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 


A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 


Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 


Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.
Input
The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 10 6 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.
Output
Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.
Sample Input
6
3 1 6 4 5 2
Sample Output
60

3 5

题意:给一个数组,求它的子区间和与该区间最小值的乘积最小值

遍历每个数,把当前数a[i]作为最小值确定一个区间[l,r]求该区间和与a[i]的乘积,找到最小值就可以

#include<cstdio>
#include<queue>
#include<stack>
using namespace std;
typedef long long LL;
const int M = 1e5 + 5;
int a[M];
int L[M];
int R[M];
LL sum[M] = {0};
stack<int> st;
int main()
{
    int n,l,r;
    long long ans=-1, tmp;//特别注意ans赋值不应该是0!!!!
    scanf("%d", &n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d", &a[i]);
        sum[i] = sum[i-1] + a[i];
    }
    for(int i=1;i<=n;i++)
    {
        while(!st.empty()&&a[st.top()]>=a[i])
            st.pop();
        if(st.empty())
            L[i] = 1;
        else
            L[i] = st.top() + 1;
        st.push(i);
    }
    while(st.size())
        st.pop();
    for(int i=n;i>0;i--)
    {
        while(!st.empty()&&a[st.top()]>=a[i])
            st.pop();
        if(st.empty())
            R[i] = n;
        else
            R[i] = st.top() - 1;
        st.push(i);
    }
/*    for(int i=1;i<=n;i++)
        printf("index=%d,l=%d,r=%d\n",i, L[i], R[i]);*/
    for(int i=1;i<=n;i++)
    {
        tmp = (sum[R[i]] - sum[L[i]-1]) * a[i];
        if(tmp>ans)
        {
            ans = tmp;
            l = L[i];
            r = R[i];
        }
    }
    printf("%lld\n%d %d",ans, l, r);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值