Curling 2.0

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board
 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output
1
4
-1
4
10

-1

题目大意:给出一个矩阵,代表一个比赛场地,其中的1代表一个冰块,2代表冰壶开始位置,3代表冰壶终止位置,一个冰壶可以向上下左右四个方向前进,但是只能触碰到冰块才会停止,并且被触碰的冰块会消失,如果冰壶出界代表比赛结束。现在序求出从起始位置到终止位置的最短击打次数。需要注意的是当其实位置和冰块之间没有缓冲空间时间,此时不能像该方向前进。

解题思路:运用深搜进行查询最短路,因为其中的冰块再上一步触碰之后消失这个问题,用深搜更为更方便标记,其他就是向四个方向不短的搜索,知道找到最少击打次数为止。

代码:

#include<stdio.h>
#include<string.h>
int a[25][25];
int a1[4][2]={0,1,1,0,0,-1,-1,0};
int m,n,v;
int fun(int i,int x,int y)
{
int j=0;
while(x+a1[i][0]>=0&&x+a1[i][0]<n&&y+a1[i][1]>=0&&y+a1[i][1]<m&&a[x+a1[i][0]][y+a1[i][1]]==0)
{
x+=a1[i][0];
y+=a1[i][1];
j++;
  }
if(a[x+a1[i][0]][y+a1[i][1]]==3)
  {
    int nx,ny;
  if(a1[i][0]==0)
      return y+a1[i][1];
    else
      return x+a1[i][0];

if(j==0||x+a1[i][0]<0||x+a1[i][0]>=n||y+a1[i][1]<0||y+a1[i][1]>=m)
   return -1; 
if(a1[i][0]==0)
   return y;
else
   return x;
}
void dfs(int x,int y,int z)
{
int i;
if(a[x][y]==3)
{
if(z<v)
 v=z;
return ; 
}
if(z>10)
 return ;
for(i=0;i<4;i++)
{
int nx,ny,k;
k=fun(i,x,y);
if(k==-1)
           continue;
   if(a1[i][0]==0)
 nx=x,ny=k;
else
  ny=y,nx=k;
if(a[nx][ny]!=3)
a[nx+a1[i][0]][ny+a1[i][1]]=0;
dfs(nx,ny,z+1);
if(a[nx][ny]!=3)
a[nx+a1[i][0]][ny+a1[i][1]]=1;

}
int main()
{
int i,j,x0,y0;
while(scanf("%d%d",&m,&n),m+n!=0)
{
memset(a,0,sizeof(a));
for(i=0;i<n;i++)
 for(j=0;j<m;j++)
   {
 scanf("%d",&a[i][j]);
 if(a[i][j]==2)
   x0=i,y0=j;
}
v=11;
a[x0][y0]=0;
dfs(x0,y0,0);
if(v==11)
 printf("-1\n");
else
 printf("%d\n",v); 
}
return 0;
}

错误分析:程序中的细节问题出错造成wa

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值