杭电acm—2135 Rolling table

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2135

Rolling table

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2937    Accepted Submission(s): 1430


Problem Description
After the 32nd ACM/ICPC regional contest, Wiskey is beginning to prepare for CET-6. He has an English words table and read it every morning.
One day, Wiskey's chum wants to play a joke on him. He rolling the table, and tell Wiskey how many time he rotated. Rotate 90 degrees clockwise or count-clockwise each time.
The table has n*n grids. Your task is tell Wiskey the final status of the table.
 

Input
Each line will contain two number.
The first is postive integer n (0 < n <= 10).
The seconed is signed 32-bit integer m.
if m is postive, it represent rotate clockwise m times, else it represent rotate count-clockwise -m times.
Following n lines. Every line contain n characters.
 

Output
Output the n*n grids of the final status.
 

Sample Input
  
  
3 2 123 456 789 3 -1 123 456 789
 

Sample Output
  
  
987 654 321 369 258 147
 

Author
Wiskey
 

Source
这个题目需要细心呐,仔细的考虑清楚四种情况的打印情况即可,最好在本子自己画画,演算一下分布的规律
AC代码如下:(如有错误和建议,请大家不吝指出)
#include<stdio.h>
int main(){
	int m,n;
	char ans[15][15];
	while(scanf("%d%d",&n,&m)!=EOF){
		getchar();
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++)
			  scanf("%c",&ans[i][j]);
			getchar();
	    }
		int x=m%4;
		if(x<0)
		  x+=4;
		if(x==0){
			for(int i=0;i<n;i++){
				for(int j=0;j<n;j++)
				  printf("%c",ans[i][j]);
				printf("\n");
			}
		}else if(x==1){
			for(int i=0;i<n;i++){
				for(int j=n-1;j>=0;j--)
				  printf("%c",ans[j][i]);
				printf("\n");
			}
		}else if(x==2){
			for(int i=n-1;i>=0;i--){
				for(int j=n-1;j>=0;j--)
				  printf("%c",ans[i][j]);
				printf("\n");
			}
		}else if(x==3){
			for(int i=n-1;i>=0;i--){
				for(int j=0;j<n;j++)
				  printf("%c",ans[j][i]);
				printf("\n");
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值